summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-secman/lc-secman-9999.ebuild')
-rw-r--r--app-leechcraft/lc-secman/lc-secman-9999.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/app-leechcraft/lc-secman/lc-secman-9999.ebuild b/app-leechcraft/lc-secman/lc-secman-9999.ebuild
index 7758cdc51ab8..37f8d40d9992 100644
--- a/app-leechcraft/lc-secman/lc-secman-9999.ebuild
+++ b/app-leechcraft/lc-secman/lc-secman-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit leechcraft
@@ -10,7 +10,18 @@ DESCRIPTION="Security and personal data manager for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug"
+IUSE="debug crypt"
-DEPEND="~app-leechcraft/lc-core-${PV}"
+DEPEND="~app-leechcraft/lc-core-${PV}
+ crypt? ( dev-libs/openssl:0 )
+ dev-qt/qtwidgets:5
+"
RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_SECMAN_SECURESTORAGE=$(usex crypt)
+ )
+
+ cmake-utils_src_configure
+}