summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics/process-exporter/process-exporter-0.7.10.ebuild')
-rw-r--r--app-metrics/process-exporter/process-exporter-0.7.10.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-metrics/process-exporter/process-exporter-0.7.10.ebuild b/app-metrics/process-exporter/process-exporter-0.7.10.ebuild
new file mode 100644
index 000000000000..3d4199894c57
--- /dev/null
+++ b/app-metrics/process-exporter/process-exporter-0.7.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="Process exporter for prometheus"
+HOMEPAGE="https://github.com/ncabatoff/process-exporter"
+SRC_URI="https://github.com/ncabatoff/process-exporter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.md
+ insinto /etc/${PN}
+ doins packaging/conf/all.yaml
+ systemd_dounit packaging/${PN}.service
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ keepdir /var/log/${PN}
+}