summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/birthday/birthday-1.6.2.ebuild')
-rw-r--r--app-misc/birthday/birthday-1.6.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/birthday/birthday-1.6.2.ebuild b/app-misc/birthday/birthday-1.6.2.ebuild
new file mode 100644
index 000000000000..600b93523b1b
--- /dev/null
+++ b/app-misc/birthday/birthday-1.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a list of events happening in the near future"
+HOMEPAGE="http://sourceforge.net/projects/birthday/"
+SRC_URI="mirror://sourceforge/birthday/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't strip, install in correct share dir and respect CFLAGS
+ sed -i -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}