summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/delay')
-rw-r--r--app-misc/delay/delay-1.6-r5.ebuild (renamed from app-misc/delay/delay-1.6-r2.ebuild)25
-rw-r--r--app-misc/delay/delay-1.6-r6.ebuild50
-rw-r--r--app-misc/delay/files/delay-1.6-clang16.patch12
3 files changed, 73 insertions, 14 deletions
diff --git a/app-misc/delay/delay-1.6-r2.ebuild b/app-misc/delay/delay-1.6-r5.ebuild
index e4feba5f19c2..403d03af2144 100644
--- a/app-misc/delay/delay-1.6-r2.ebuild
+++ b/app-misc/delay/delay-1.6-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -11,21 +11,18 @@ SRC_URI="https://onegeek.org/~tom/software/delay/dl/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-RDEPEND="sys-libs/ncurses:0="
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-src_prepare() {
- eapply \
- "${FILESDIR}"/${P}-headers.patch \
- "${FILESDIR}"/${P}-tinfo.patch
-
- mv configure.in configure.ac || die
+PATCHES=(
+ "${FILESDIR}"/${P}-headers.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+src_prepare() {
default
eautoreconf
}
diff --git a/app-misc/delay/delay-1.6-r6.ebuild b/app-misc/delay/delay-1.6-r6.ebuild
new file mode 100644
index 000000000000..1f6d50b396c9
--- /dev/null
+++ b/app-misc/delay/delay-1.6-r6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edo
+
+DESCRIPTION="Sleeplike program that counts down the number of seconds specified"
+HOMEPAGE="https://onegeek.org/~tom/software/delay/"
+SRC_URI="https://onegeek.org/~tom/software/delay/dl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/byacc
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-headers.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Our clang16 patch forces regeneration of the yacc files and going from
+ # an ancient bison to a modern one makes 'delay until now + 5 minutes'
+ # segfault. It happens even if the patch is empty, as the regeneration
+ # is the breaking part. So, just force byacc, as it seems to work, and
+ # this is a package with no active upstream.
+ export YACC=byacc
+
+ econf
+}
+
+src_test() {
+ # No provided test suite, so let's add a smoketest which would've
+ # caught the segfault part of bug #881319.
+ edo ./delay 5
+ edo ./delay until now + 1 minutes
+}
diff --git a/app-misc/delay/files/delay-1.6-clang16.patch b/app-misc/delay/files/delay-1.6-clang16.patch
new file mode 100644
index 000000000000..5deec4ea5194
--- /dev/null
+++ b/app-misc/delay/files/delay-1.6-clang16.patch
@@ -0,0 +1,12 @@
+--- a/parsetimey.y
++++ b/parsetimey.y
+@@ -7,6 +7,9 @@
+
+ #define YYDEBUG 1
+
++int yyerror(char *s);
++int yylex(void);
++
+ time_t currtime;
+ struct tm exectm;
+ static int isgmt;