summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/detox/detox-1.2.0-r3.ebuild')
-rw-r--r--app-misc/detox/detox-1.2.0-r3.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/app-misc/detox/detox-1.2.0-r3.ebuild b/app-misc/detox/detox-1.2.0-r3.ebuild
deleted file mode 100644
index 2ec1846e2a59..000000000000
--- a/app-misc/detox/detox-1.2.0-r3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit epatch
-
-MY_P="${PN}-${PV/_/-}"
-
-DESCRIPTION="Safely remove spaces and strange characters from filenames"
-HOMEPAGE="http://detox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~mips ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-S="${WORKDIR}"/${MY_P}
-
-RDEPEND="
- dev-libs/popt
- !dev-python/detox"
-
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
- sys-devel/bison"
-
-PATCHES=(
- "${FILESDIR}"/${P}-parallel.patch
- "${FILESDIR}"/${P}-LDFLAGS.patch
- "${FILESDIR}"/${P}-change-default-sequence-to-use-utf8-table.patch
- "${FILESDIR}"/${P}-install-missing-file.patch
- "${FILESDIR}"/${P}-format-security.patch
- )
-
-src_prepare() {
- sed \
- -e 's:Fl c Ar:Fl f Ar:g' \
- -i ${PN}.1 || die
- epatch "${PATCHES[@]}"
- sed \
- -e '/detoxrc.sample/d' \
- -i Makefile.in || die
-}
-
-src_configure() {
- econf --with-popt="${EPREFIX}/usr"
-}