summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/empty/empty-0.6.23c.ebuild')
-rw-r--r--app-misc/empty/empty-0.6.23c.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/empty/empty-0.6.23c.ebuild b/app-misc/empty/empty-0.6.23c.ebuild
new file mode 100644
index 000000000000..6a270f84a82b
--- /dev/null
+++ b/app-misc/empty/empty-0.6.23c.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small shell utility, similar to expect(1)"
+HOMEPAGE="http://empty.sourceforge.net"
+SRC_URI="https://download.sourceforge.net/empty/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+
+RDEPEND="virtual/logger"
+
+PATCHES=( "${FILESDIR}/${PN}-respect-LDFLAGS.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin empty
+ doman empty.1
+ dodoc README.txt
+ dodoc -r examples
+}