summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fdupes/fdupes-1.51.ebuild')
-rw-r--r--app-misc/fdupes/fdupes-1.51.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/fdupes/fdupes-1.51.ebuild b/app-misc/fdupes/fdupes-1.51.ebuild
new file mode 100644
index 000000000000..6bff666e0637
--- /dev/null
+++ b/app-misc/fdupes/fdupes-1.51.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P="${PN}-${PV/_pre/-PR}"
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes https://code.google.com/p/fdupes/"
+SRC_URI="
+ https://fdupes.googlecode.com/files/${P}.tar.gz
+ https://github.com/adrianlopezroche/${PN}/archive/${P}.tar.gz
+ "
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${PN}-1.50_pre2-compare-file.patch \
+ "${FILESDIR}"/${PN}-1.50_pre2-typo.patch
+
+ append-lfs-flags
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin fdupes
+ doman fdupes.1
+ dodoc CHANGES CONTRIBUTORS README TODO
+}