summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/geneweb')
-rw-r--r--app-misc/geneweb/Manifest2
-rw-r--r--app-misc/geneweb/geneweb-6.08-r1.ebuild76
-rw-r--r--app-misc/geneweb/geneweb-6.08-r2.ebuild77
3 files changed, 0 insertions, 155 deletions
diff --git a/app-misc/geneweb/Manifest b/app-misc/geneweb/Manifest
index 70d8a86db7c0..57f17eca5ea1 100644
--- a/app-misc/geneweb/Manifest
+++ b/app-misc/geneweb/Manifest
@@ -1,3 +1 @@
-DIST geneweb-6.08-ocaml-4.patch.gz 22259 BLAKE2B c3471b44bae06db04f51f4fbfacaf5d93388f79673686d0fdd988df482f836bd49f853c5acb3b94c39f890b7d9bd8d118b4042100c466a06a2e57227da9eee3b SHA512 333a9ca899bf454e1c534f6c890b5cbe842821573b39e9d0e432cfbdf30dbe3a495a5ecb5a9b4a00882ee51bbb3ec1ca4b417e34050a7f84e434d0424c126def
DIST geneweb-6.08.01.tar.gz 1796215 BLAKE2B 4b7d05126d244984b62ebadda3419ba8cf97326ac3103c73ca5433a8f9edeab8acd968d05942d299e70127bcf75efe5cb9a9af9f7d97ec08fd9a8a6a5aae100d SHA512 54e1ed05e540f1de167c66dee46976a8324a37ca36a9dfd6ab03105fe925053c570842e1a263499fd8bd7aecfebac8f9596b1573fcec1e104e3892337376f84d
-DIST geneweb-6.08.tar.gz 1791450 BLAKE2B 35fcd0a4087892b992b87dd4fb54b458be0e300042a237458fdeea9a4a9b8649f93261d896d6b7ad19b681b95b343013d99d99027d86b1796f74cab916178d32 SHA512 7f1d552342e8a5b05961be75c1afb768853f22cc7eb4477fa63d6a3af29ea852862ce043ae89cd1589ede20fe561ad7d77ab757cc1ecb26ce1473f0e3621b835
diff --git a/app-misc/geneweb/geneweb-6.08-r1.ebuild b/app-misc/geneweb/geneweb-6.08-r1.ebuild
deleted file mode 100644
index 55528f558666..000000000000
--- a/app-misc/geneweb/geneweb-6.08-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils user
-
-DESCRIPTION="Genealogy software program with a Web interface"
-HOMEPAGE="https://github.com/geneanet/geneweb"
-SRC_URI="https://github.com/geneweb/geneweb/archive/v6.08.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~tupone/${P}-ocaml-4.patch.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+ocamlopt"
-RESTRICT="strip"
-
-RDEPEND="dev-lang/ocaml[ocamlopt?]
- dev-ml/camlp5[ocamlopt?]"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${WORKDIR}"/${P}-ocaml-4.patch
- "${FILESDIR}"/${PF}-gentoo.patch
- "${FILESDIR}"/${P}-parallellbuild.patch )
-
-src_compile() {
- if use ocamlopt; then
- emake
- else
- emake OCAMLC=ocamlc OCAMLOPT=ocamlopt out
- # If using bytecode we dont want to strip the binary as it would remove
- # the bytecode and only leave ocamlrun...
- fi
-}
-
-src_install() {
- dodoc ICHANGES
- emake new_distrib
- emake wrappers
- # Install doc
- cd distribution
- dodoc CHANGES.txt
- # Install binaries
- cd gw
- dobin gwc gwc1 gwc2 consang gwd gwu update_nldb ged2gwb ged2gwb2 gwb2ged gwsetup
- insinto /usr/lib/${PN}
- doins -r gwtp_tmp/*
- dodoc a.gwf
- insinto /usr/share/${PN}
- doins -r etc images lang setup gwd.arg only.txt
-
- cd ../..
-
- # Install binaries
- dobin src/check_base
- # Install manpages
- doman man/*
-
- # Install doc
- dodoc -r contrib
- docompress -x /usr/share/doc/${PF}/contrib
-
- newinitd "${FILESDIR}/geneweb.initd" geneweb
- newconfd "${FILESDIR}/geneweb.confd" geneweb
-}
-
-pkg_postinst() {
- enewuser geneweb "" "/bin/bash" /var/lib/geneweb
- einfo "A CGI program has been installed in /usr/lib/${PN}. Follow the"
- einfo "instructions on the README in that directory to use it"
- einfo "For 64 bits architecture you need to rebuild the database"
- einfo "\"gwu foo > foo.gw \" will save the database (use the previous"
- einfo "version to do that). \"gwc2 foo.gw -o bar \" will restore it "
- einfo "(using the current package)"
-}
diff --git a/app-misc/geneweb/geneweb-6.08-r2.ebuild b/app-misc/geneweb/geneweb-6.08-r2.ebuild
deleted file mode 100644
index a962e673485d..000000000000
--- a/app-misc/geneweb/geneweb-6.08-r2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit eutils
-
-DESCRIPTION="Genealogy software program with a Web interface"
-HOMEPAGE="https://github.com/geneanet/geneweb"
-SRC_URI="https://github.com/geneweb/geneweb/archive/v6.08.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~tupone/${P}-ocaml-4.patch.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
-RESTRICT="strip"
-
-RDEPEND="dev-lang/ocaml[ocamlopt?]
- dev-ml/camlp5[ocamlopt?]
- acct-user/geneweb
- acct-group/geneweb"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${WORKDIR}"/${P}-ocaml-4.patch
- "${FILESDIR}"/${P}-r1-gentoo.patch
- "${FILESDIR}"/${P}-parallellbuild.patch )
-
-src_compile() {
- if use ocamlopt; then
- emake
- else
- emake OCAMLC=ocamlc OCAMLOPT=ocamlopt out
- # If using bytecode we dont want to strip the binary as it would remove
- # the bytecode and only leave ocamlrun...
- fi
-}
-
-src_install() {
- dodoc ICHANGES
- emake new_distrib
- emake wrappers
- # Install doc
- cd distribution
- dodoc CHANGES.txt
- # Install binaries
- cd gw
- dobin gwc gwc1 gwc2 consang gwd gwu update_nldb ged2gwb ged2gwb2 gwb2ged gwsetup
- insinto /usr/lib/${PN}
- doins -r gwtp_tmp/*
- dodoc a.gwf
- insinto /usr/share/${PN}
- doins -r etc images lang setup gwd.arg only.txt
-
- cd ../..
-
- # Install binaries
- dobin src/check_base
- # Install manpages
- doman man/*
-
- # Install doc
- dodoc -r contrib
- docompress -x /usr/share/doc/${PF}/contrib
-
- newinitd "${FILESDIR}/geneweb.initd" geneweb
- newconfd "${FILESDIR}/geneweb.confd" geneweb
-}
-
-pkg_postinst() {
- einfo "A CGI program has been installed in /usr/lib/${PN}. Follow the"
- einfo "instructions on the README in that directory to use it"
- einfo "For 64 bits architecture you need to rebuild the database"
- einfo "\"gwu foo > foo.gw \" will save the database (use the previous"
- einfo "version to do that). \"gwc2 foo.gw -o bar \" will restore it "
- einfo "(using the current package)"
-}