summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/lcd4linux')
-rw-r--r--app-misc/lcd4linux/files/lcd4linux-0.11.0_pre20170527-libtool.patch40
-rw-r--r--app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r7.ebuild (renamed from app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild)20
-rw-r--r--app-misc/lcd4linux/metadata.xml4
3 files changed, 54 insertions, 10 deletions
diff --git a/app-misc/lcd4linux/files/lcd4linux-0.11.0_pre20170527-libtool.patch b/app-misc/lcd4linux/files/lcd4linux-0.11.0_pre20170527-libtool.patch
new file mode 100644
index 000000000000..3ba98fdc1503
--- /dev/null
+++ b/app-misc/lcd4linux/files/lcd4linux-0.11.0_pre20170527-libtool.patch
@@ -0,0 +1,40 @@
+Upstream-PR: https://github.com/jmccrohan/lcd4linux/pull/3
+
+From cffb509a8471b26177de0887e5461a408fdb8e35 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Mon, 20 Jun 2022 17:43:23 -0700
+Subject: [PATCH] configure: Use macros earlier
+
+When building with slibtool using the rlibtool symlink the build will
+fail because it doesn't find the generated libtool. This is required so
+rlibtool can determine if its a shared or static build.
+
+This can be fixed easily by using LT_INIT earlier before AC_OUTPUT.
+Generally these should be used near the top of configure.ac.
+
+Gentoo Bug: https://bugs.gentoo.org/783492
+--- a/configure.ac
++++ b/configure.ac
+@@ -29,6 +29,7 @@
+
+ AC_PREREQ(2.59)
+ AC_INIT([LCD4Linux],[0.11.0-SVN],[lcd4linux-users@lists.sourceforge.net])
++AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_SRCDIR([lcd4linux.c])
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER(config.h)
+@@ -40,6 +41,7 @@ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+ PKG_PROG_PKG_CONFIG
++LT_INIT
+
+ # dmalloc
+ AM_WITH_DMALLOC
+@@ -171,6 +173,3 @@ AC_MSG_RESULT(
+ [ $PLUGINS]
+ [-----------------------------------------]
+ )
+-
+-AC_CONFIG_MACRO_DIR([m4])
+-LT_INIT
diff --git a/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild b/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r7.ebuild
index cfb01cb28216..36408d98a831 100644
--- a/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild
+++ b/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit autotools flag-o-matic python-single-r1
@@ -24,7 +24,7 @@ REQUIRED_USE="
# Some drivers were removed from this list:
# - lcdlinux: It's an ancient driver, which needs app-misc/lcd-linux, that made it never to the portage tree.
# - lcdlinux: Besides, app-misc/lcd-linux won't compile on a modern linux kernel.
-# - st2205: It's needs dev-libs/libst2205, which made it never to the portage tree and is quite outdated.
+# - st2205: It's needs dev-libs/libst2205, which made it never to the portage tree and is quite outdated.
IUSE_LCD_DEVICES=(
ASTUSB BeckmannEgle BWCT CrystalFontz Curses Cwlinux D4D DPF EA232graphic EFN FutabaVFD
FW8888 G15 GLCD2USB HD44780 HD44780-I2C IRLCD LCD2USB LCDTerm LEDMatrix LPH7508 LUIse LW_ABP M50530
@@ -126,9 +126,12 @@ RDEPEND="
DEPEND="${RDEPEND}"
-BDEPEND="sys-devel/autoconf-archive"
+BDEPEND="dev-build/autoconf-archive"
-PATCHES="${FILESDIR}/${P}-python3.patch"
+PATCHES=(
+ "${FILESDIR}/${P}-libtool.patch" # 783492
+ "${FILESDIR}/${P}-python3.patch"
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -142,7 +145,8 @@ src_prepare() {
rm ax_python_devel.m4
# Use correct python version.
- append-libs "-lpython${EPYTHON#python}m"
+ # (See: bug #793869)
+ append-libs $(python_get_LIBS)
fi
eautoreconf
@@ -193,6 +197,6 @@ src_install() {
pkg_postinst() {
if [[ ! -z ${REPLACING_VERSIONS} ]]; then
- use python && einfo "Starting with that version, the python plugins uses now python3 instead if python2!"
+ use python && einfo "Starting with this version, the python plugins now uses python3 instead of python2!"
fi
}
diff --git a/app-misc/lcd4linux/metadata.xml b/app-misc/lcd4linux/metadata.xml
index a7279fdf0c72..7d64ef2eb48e 100644
--- a/app-misc/lcd4linux/metadata.xml
+++ b/app-misc/lcd4linux/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>conikost@gentoo.org</email>
@@ -39,7 +39,7 @@
<flag name="outb">Enable raw i/o access.</flag>
<flag name="pop3">Enable the pop3 plugin, to get notified about new mails.</flag>
<flag name="proc-stat">Enable the proc_stat plugin, to read data from the proc file system.</flag>
- <flag name="python">Enable support for dev-lang/python and enable the python plugin, to execute own python scripts.</flag>
+ <flag name="python">Enable support for <pkg>dev-lang/python</pkg> and enable the python plugin, to execute own python scripts.</flag>
<flag name="qnaplog">Enable the qnaplog plugin, to read a log from a QNAP device.</flag>
<flag name="raspi">Enable the raspi plugin, to read sensor data from a Raspberry Pi.</flag>
<flag name="sample">Enable the sample plugin.</flag>