summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/lcd4linux')
-rw-r--r--app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild b/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild
index 4415c3b2ae7b..ef4a8ada7cf3 100644
--- a/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild
+++ b/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit autotools flag-o-matic python-single-r1
@@ -142,11 +142,7 @@ src_prepare() {
rm ax_python_devel.m4
# Use correct python version.
- if use python_single_target_python3_6 || use python_single_target_python3_7; then
- append-libs "-lpython${EPYTHON#python}m"
- else
- append-libs "-lpython${EPYTHON#python}"
- fi
+ append-libs "-lpython${EPYTHON#python}$(usex python_single_target_python3_7 'm' '')"
fi
eautoreconf