summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmux/tmux-9999.ebuild')
-rw-r--r--app-misc/tmux/tmux-9999.ebuild48
1 files changed, 30 insertions, 18 deletions
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index 04927c56269f..c213890ee26b 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -1,66 +1,78 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools flag-o-matic
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="https://tmux.github.io/"
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
EGIT_REPO_URI="https://github.com/tmux/tmux.git"
else
- SRC_URI="https://github.com/tmux/tmux/releases/download/$(ver_cut 1-2)/${P/_/-}.tar.gz"
- [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ SRC_URI="https://github.com/tmux/tmux/releases/download/${PV}/${P/_/-}.tar.gz"
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ fi
S="${WORKDIR}/${P/_/-}"
fi
LICENSE="ISC"
SLOT="0"
-IUSE="debug selinux utempter vim-syntax kernel_FreeBSD kernel_linux"
+IUSE="debug selinux systemd utempter vim-syntax"
DEPEND="
- dev-libs/libevent:0=
- sys-libs/ncurses:0=
+ dev-libs/libevent:=
+ sys-libs/ncurses:=
+ systemd? ( sys-apps/systemd:= )
utempter? ( sys-libs/libutempter )
+ kernel_Darwin? ( dev-libs/libutf8proc:= )
"
BDEPEND="
virtual/pkgconfig
- virtual/yacc
+ app-alternatives/yacc
"
RDEPEND="
${DEPEND}
selinux? ( sec-policy/selinux-screen )
- vim-syntax? ( app-vim/vim-tmux )"
+ vim-syntax? ( app-vim/vim-tmux )
+"
+
+# BSD only functions
+QA_CONFIG_IMPL_DECL_SKIP=( strtonum recallocarray )
DOCS=( CHANGES README )
PATCHES=(
- "${FILESDIR}/${PN}-2.4-flags.patch"
-
- # upstream fixes (can be removed with next version bump)
+ "${FILESDIR}"/${PN}-2.4-flags.patch
)
src_prepare() {
- # bug 438558
- # 1.7 segfaults when entering copy mode if compiled with -Os
- replace-flags -Os -O2
-
default
eautoreconf
}
src_configure() {
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+
local myeconfargs=(
--sysconfdir="${EPREFIX}"/etc
$(use_enable debug)
+ $(use_enable systemd)
$(use_enable utempter)
+
+ # For now, we only expose this for macOS, because
+ # upstream strongly encourage it. I'm not sure it's
+ # needed on Linux right now.
+ $(use_enable kernel_Darwin utf8proc)
)
+
econf "${myeconfargs[@]}"
}