summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/utimer/utimer-0.4.ebuild')
-rw-r--r--app-misc/utimer/utimer-0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/utimer/utimer-0.4.ebuild b/app-misc/utimer/utimer-0.4.ebuild
new file mode 100644
index 000000000000..9feea5d8b5c3
--- /dev/null
+++ b/app-misc/utimer/utimer-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="A command line timer and stopwatch"
+HOMEPAGE="http://utimer.codealpha.net/utimer"
+SRC_URI="http://utimer.codealpha.net/dl.php?file=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug nls"
+
+DEPEND=">=dev-libs/glib-2.18.2
+ >=dev-util/intltool-0.40.5"
+RDEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=
+ if use debug; then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+ econf ${myconf} $(use_enable nls)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "failed to install"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}