summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/yq/yq-2.9.2-r1.ebuild')
-rw-r--r--app-misc/yq/yq-2.9.2-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/app-misc/yq/yq-2.9.2-r1.ebuild b/app-misc/yq/yq-2.9.2-r1.ebuild
deleted file mode 100644
index fd0f228dd869..000000000000
--- a/app-misc/yq/yq-2.9.2-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Command-line YAML processor - jq wrapper for YAML documents"
-HOMEPAGE="https://yq.readthedocs.io/ https://github.com/kislyuk/yq/ https://pypi.org/project/yq/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-misc/jq
- >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/toml[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- sed -e 's:unittest.main():unittest.main(verbosity=2):' \
- -i test/test.py || die
-
- sed -r -i 's:[[:space:]]*"coverage",:: ; s:[[:space:]]*"flake8",::' \
- setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" test/test.py || die "tests failed under ${EPYTHON}"
-}