summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/filebus/Manifest1
-rw-r--r--app-misc/filebus/filebus-0.3.2.ebuild68
-rw-r--r--app-misc/filebus/metadata.xml2
3 files changed, 70 insertions, 1 deletions
diff --git a/app-misc/filebus/Manifest b/app-misc/filebus/Manifest
index 11546b7cb6b1..f3d9ec635d04 100644
--- a/app-misc/filebus/Manifest
+++ b/app-misc/filebus/Manifest
@@ -1 +1,2 @@
DIST filebus-0.3.1.tar.gz 16926 BLAKE2B 87eea36a58895a89a70e236f505af09efabf37ce04ce58c713dc99222e415f0ecd9a55fc921a9b6336f4dea04c5e3860252425e257706f0e37be3d43d76668c0 SHA512 e0d4e30f478c9ae95b520122b5aa70bc792d7caad9f9dbde6a72dec9eff314ca884b0291ed9ad662998d1e0e91679dc96ec749b33f55188fab61e7b2b5baa792
+DIST filebus-0.3.2.tar.gz 17310 BLAKE2B 0f30aabcd316f52ea12d12b136befe643085dff5e283f65edf2a459b127cd3e2d48c472ae0dd8f302bb7211e4da5541a6fc7ac274573631ab03fc246bc8b566f SHA512 88ce3cd2d8aec7afd30d16315a6a8a37dee1b21d882571ef87c7dca56251e737d6500a5fad0124c62aea6383aae5ec30abd8abf86c2fac5d582f8fe96049eaa6
diff --git a/app-misc/filebus/filebus-0.3.2.ebuild b/app-misc/filebus/filebus-0.3.2.ebuild
new file mode 100644
index 000000000000..cfa1df91be48
--- /dev/null
+++ b/app-misc/filebus/filebus-0.3.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A user space multicast named pipe implementation backed by a regular file"
+HOMEPAGE="https://github.com/pipebus/filebus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="+inotify python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+ )"
+BDEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ if use python; then
+ distutils-r1_src_prepare
+ fi
+}
+
+src_compile() {
+ if use python; then
+ distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ "${BASH}" ./lib/bash/filebus-test.bash test || die
+
+ if use python; then
+ distutils-r1_src_test
+ fi
+}
+
+python_test() {
+ python test/test_filebus.py || die "tests failed for ${EPYTHON}"
+}
+
+src_install() {
+ if use python; then
+ distutils-r1_src_install
+ else
+ insinto /usr/libexec/filebus
+ doins lib/bash/*.bash
+ cat <<-EOF > "${T}/filebus"
+ #!/bin/sh
+ exec bash "${EPREFIX}/usr/libexec/filebus/filebus.bash" "\$@"
+ EOF
+ dobin "${T}/filebus"
+ dosym filebus /usr/bin/pipebus
+ fi
+}
diff --git a/app-misc/filebus/metadata.xml b/app-misc/filebus/metadata.xml
index e83dcf85167b..063cf040c7b7 100644
--- a/app-misc/filebus/metadata.xml
+++ b/app-misc/filebus/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<upstream>
- <remote-id type="github">zmedico/filebus</remote-id>
+ <remote-id type="github">pipebus/filebus</remote-id>
<remote-id type="pypi">filebus</remote-id>
</upstream>
<maintainer type="person">