summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/conmux/Manifest1
-rw-r--r--app-misc/conmux/conmux-0.16.4.ebuild70
-rw-r--r--app-misc/conmux/files/conmux-0.16.4_unexpected-paths.patch11
3 files changed, 82 insertions, 0 deletions
diff --git a/app-misc/conmux/Manifest b/app-misc/conmux/Manifest
index f2af53d8cd28..f5e8eca99c8c 100644
--- a/app-misc/conmux/Manifest
+++ b/app-misc/conmux/Manifest
@@ -1 +1,2 @@
+DIST autotest-0.16.4.tar.gz 14699617 BLAKE2B faae9fe2472ef6cde5868368d81eeb6b855af7684b407b307d14dbd7e8800506c4234b38b254a58b4d915290dcd61e6c9f2eb4d04cd3b929462b0a6d8ffc52cf SHA512 e209d008d7987610f20b7f0c932f8909a82bdde4c13f0362f54f5872464c76f1e3da5760d8eb0f42567249dee4db5f7802478be5c9798b46e2b421f31aa1cbdd
DIST conmux-0.15.1.tar.gz 50713 BLAKE2B d764d63f03318614ad0d7088911dee02fbd36d24da7dc988bb3db03cda3e60c5b185f50b5545b086e2a3a7b278aa47af7bfd211c39c88f7ada32e83666eea0c5 SHA512 8138d6d10b4382709828277503d1c23c52fd43109ebad79073be9003c39a9e62c2b7d9d6e78a9e81797c22871985e50a58df0d538ff63e3f580c9a229b520107
diff --git a/app-misc/conmux/conmux-0.16.4.ebuild b/app-misc/conmux/conmux-0.16.4.ebuild
new file mode 100644
index 000000000000..cd2a1cf087d5
--- /dev/null
+++ b/app-misc/conmux/conmux-0.16.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DIST_TEST="skip"
+
+MY_PN="autotest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A console multiplexor"
+HOMEPAGE="https://github.com/autotest/autotest"
+SRC_URI="https://github.com/autotest/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="dev-perl/IO-Multiplex
+ dev-perl/URI"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.16.4_unexpected-paths.patch
+)
+
+S="${WORKDIR}"/${MY_P}/conmux
+
+src_prepare() {
+ default
+ # manual installation of drivers and helpers
+ sed -i -e "/include/d" Makefile || die "Failed to fix Makefile"
+}
+
+src_install() {
+ perl_set_version
+ emake BASE="${ED}/usr" install
+ # helpers and drivers have been removed in src_prepare
+ insinto /usr/share/${PN}/
+ doins -r drivers/ helpers/
+ fperms -R 0750 /usr/share/${PN}/{drivers,helpers}/
+ keepdir /etc/${PN}
+ # no need to have the init script in /sbin
+ rm "${ED}"/usr/sbin/start || die "failed to remove init script"
+ # console is too generic. Make it conmux-console instead
+ mv "${ED}"/usr/bin/console "${ED}"/usr/bin/${PN}-console || \
+ die "failed to rename console to conmux-console"
+ # Fix up directory for the module
+ perl_set_version
+ keepdir ${VENDOR_LIB}/${PN}
+ mv "${ED}"/usr/lib/Conmux.pm "${ED}"/${VENDOR_LIB}/. || \
+ die "failed to move the Conmux.pm module"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newinitd "${FILESDIR}"/${PN}-registry.initd ${PN}-registry
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newconfd "${FILESDIR}"/${PN}-registry.confd ${PN}-registry
+ dodoc README
+}
+
+pkg_postinst() {
+ elog
+ elog "If you have more than one serial ports and you want to use all"
+ elog "of them with conmux, copy and paste the 'conmux' init.d and conf.d"
+ elog "files as many times as you want, pointing each conf.d file to the"
+ elog "device's configuration file."
+ elog
+ elog "See /etc/conf.d/conmux for more information"
+ elog
+}
diff --git a/app-misc/conmux/files/conmux-0.16.4_unexpected-paths.patch b/app-misc/conmux/files/conmux-0.16.4_unexpected-paths.patch
new file mode 100644
index 000000000000..7b330158fdc4
--- /dev/null
+++ b/app-misc/conmux/files/conmux-0.16.4_unexpected-paths.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,8 +18,6 @@
+ @[ -d $(BASE)/bin ] || mkdir $(BASE)/bin
+ @[ -d $(BASE)/lib ] || mkdir $(BASE)/lib
+ @[ -d $(BASE)/sbin ] || mkdir $(BASE)/sbin
+- @[ -d $(BASE)/log ] || mkdir $(BASE)/log
+- @[ -d $(BASE)/etc ] || mkdir $(BASE)/etc
+ for f in $(BINS); do \
+ rm -f $(BASE)/bin/$$f; \
+ cp -p $$f $(BASE)/bin/$$f; \