summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/cobex')
-rw-r--r--app-mobilephone/cobex/Manifest1
-rw-r--r--app-mobilephone/cobex/cobex-0.2.13.ebuild31
-rw-r--r--app-mobilephone/cobex/files/cobex-0.2.13-build.patch108
-rw-r--r--app-mobilephone/cobex/metadata.xml8
4 files changed, 0 insertions, 148 deletions
diff --git a/app-mobilephone/cobex/Manifest b/app-mobilephone/cobex/Manifest
deleted file mode 100644
index be633ffb2ad3..000000000000
--- a/app-mobilephone/cobex/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cobex-0.2.13.tar.gz 27020 BLAKE2B cb5dc2a52f8e94bb3d59d64e15f730f04a8315b9ff668314795621fb0b90fd2293d343b6210a21df9c3c284ae698deba6cd6973b19d439447edaa7077d32fa8a SHA512 f05293d9d9f9fdf04809f2a5395bf8be3dd8bfbc592a9ca93b3b2e9b2a78157291b6d38e53b9c7f86e0e32567ee6d4028a9c48062eab4640c9cd85894e7e6a84
diff --git a/app-mobilephone/cobex/cobex-0.2.13.ebuild b/app-mobilephone/cobex/cobex-0.2.13.ebuild
deleted file mode 100644
index 060d72031b58..000000000000
--- a/app-mobilephone/cobex/cobex-0.2.13.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-DESCRIPTION="small implementation of Obex for phones using the DCU-11 USB-to-serial adapter"
-HOMEPAGE="http://cobex.sourceforge.net/"
-SRC_URI="mirror://sourceforge/cobex/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="dev-libs/libezV24
- dev-libs/expat"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-build.patch
- local f
- for f in get ls mkdir put rm ; do mv ${f}.c cobex_${f}.c || die ; done
-}
-
-src_install() {
- dobin cobex_{ls,mkdir,put,rm} || die
- dodoc Changelog README Things_to_know_T310.txt
-}
diff --git a/app-mobilephone/cobex/files/cobex-0.2.13-build.patch b/app-mobilephone/cobex/files/cobex-0.2.13-build.patch
deleted file mode 100644
index 32ac20deb671..000000000000
--- a/app-mobilephone/cobex/files/cobex-0.2.13-build.patch
+++ /dev/null
@@ -1,108 +0,0 @@
---- Makefile
-+++ Makefile
-@@ -1,75 +1,37 @@
--CC=gcc
--CCFLAGS=-O2 -Wall
--EXTRACCFLAGS=-s -lezV24
--EXPATCCFLAGS=-lexpat
--CFILES=put.c get.c cobex_core.c ls.c cobex_tools.c cobex_serial.c rm.c mkdir.c
--HFILES=cobex_defs.h cobex_core.h capabilities.h cobex_tools.h cobex_serial.h
--O2FILES=cobex_core.o cobex_tools.o cobex_serial.o
--PUTO=put.o
--GETO=get.o
--LSO=ls.o
--RMO=rm.o
--MKDIRO=mkdir.o
--CAPAO=capability.o
--COBEXPUT=cobex_put
--COBEXGET=cobex_get
--COBEXLS=cobex_ls
--COBEXRM=cobex_rm
--COBEXCAPA=cobex_capa
--COBEXMKDIR=cobex_mkdir
-+CC ?= gcc
-+CFLAGS ?= -O2
-+CFLAGS += -Wall
-+LDLIBS += -lezV24
-+
-+PROGS = cobex_put cobex_get cobex_ls cobex_rm cobex_mkdir
-+CFILES = $(wildcard *.c)
-+HFILES = $(wildcard *.h)
-+O2FILES = cobex_core.o cobex_tools.o cobex_serial.o
-+
- EXTRAFILES = README Changelog COPYING Makefile cobex_put.pl Things_to_know_T310.txt Hacking_pl2303_driver.txt
- VERSION = 0.2.13
- PROJNAME = cobex-$(VERSION)
-
--all: $(COBEXPUT) $(COBEXGET) $(COBEXLS) $(COBEXRM) $(COBEXMKDIR)
-+all: $(PROGS)
-
- model:
- cd modeldb && make all
-
--$(COBEXPUT): $(O2FILES) $(PUTO)
-- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXPUT) $(PUTO) $(O2FILES)
--
--$(COBEXGET): $(O2FILES) $(GETO)
-- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXGET) $(GETO) $(O2FILES)
--
--$(COBEXRM): $(O2FILES) $(RMO)
-- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXRM) $(RMO) $(O2FILES)
--
--$(COBEXLS): $(O2FILES) $(LSO)
-- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) $(EXPATCCFLAGS) -o $(COBEXLS) $(LSO) $(O2FILES)
--
--$(COBEXCAPA): $(O2FILES) $(CAPAO)
-- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXCAPA) $(CAPAO) $(O2FILES)
--
--$(COBEXMKDIR): $(O2FILES) $(MKDIRO)
-- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) -o $(COBEXMKDIR) $(MKDIRO) $(O2FILES)
--
--
--test2: $(O2FILES) test2.o
-- $(CC) $(CCFLAGS) $(EXTRACCFLAGS) $(EXPATCCFLAGS) -o test2 test2.o $(O2FILES)
--
--.c.o:
-- $(CC) $(CCFLAGS) $(LOCKSERIAL) -c $<
--
--$(PUTO): put.c $(O2FILES)
--
--$(GETO): get.c $(O2FILES)
--
--$(LSO): ls.c $(O2FILES)
--
--$(RMO): rm.c $(O2FILES)
--
--test2.o: test2.c $(O2FILES)
--
--cobex_core.o: cobex_core.c cobex_core.h cobex_defs.h
--
--cobex_tools.o: cobex_tools.c cobex_tools.h cobex_defs.h cobex_core.c cobex_core.h
--
--cobex_serial.o: cobex_serial.c cobex_serial.h cobex_core.c cobex_core.h
-+cobex_put: $(O2FILES)
-+cobex_get: $(O2FILES)
-+cobex_ls: $(O2FILES)
-+cobex_rm: $(O2FILES)
-+cobex_mkdir: $(O2FILES)
-+cobex_capa: $(O2FILES)
-+
-+cobex_ls: LDLIBS += -lexpat
-+
-+-include .depend
-+.depend: $(CFILES) $(HFILES)
-+ $(CC) -MM $^ > .depend
-
- clean:
-- rm -f *.o
-- cd modeldb && make clean
-+ rm -f *.o $(PROGS)
-
- printfiles: $(CFILES) $(HFILES)
- @echo $?
-@@ -88,3 +50,5 @@
-
- dist-contrib :
- cd contrib && make dist VERSION=$(VERSION)
-+
-+.PHONY: all clean dist dist2 dist-modeldb dist-contrib model printfiles
diff --git a/app-mobilephone/cobex/metadata.xml b/app-mobilephone/cobex/metadata.xml
deleted file mode 100644
index f39727f3d846..000000000000
--- a/app-mobilephone/cobex/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">cobex</remote-id>
- </upstream>
-</pkgmetadata>