summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/dfu-util/dfu-util-0.9.ebuild')
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-mobilephone/dfu-util/dfu-util-0.9.ebuild b/app-mobilephone/dfu-util/dfu-util-0.9.ebuild
new file mode 100644
index 000000000000..d5ccd44212ed
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="http://dfu-util.gnumonks.org/releases/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}