summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/heimdall')
-rw-r--r--app-mobilephone/heimdall/Manifest4
-rw-r--r--app-mobilephone/heimdall/heimdall-2.0.1.ebuild (renamed from app-mobilephone/heimdall/heimdall-1.4.2-r1.ebuild)18
-rw-r--r--app-mobilephone/heimdall/heimdall-2.0.2.ebuild (renamed from app-mobilephone/heimdall/heimdall-1.4.2.ebuild)31
-rw-r--r--app-mobilephone/heimdall/heimdall-9999.ebuild22
-rw-r--r--app-mobilephone/heimdall/metadata.xml12
5 files changed, 49 insertions, 38 deletions
diff --git a/app-mobilephone/heimdall/Manifest b/app-mobilephone/heimdall/Manifest
index db7aa53c6f4a..e9a2e5b5577c 100644
--- a/app-mobilephone/heimdall/Manifest
+++ b/app-mobilephone/heimdall/Manifest
@@ -1,2 +1,2 @@
-DIST heimdall-1.4.2.tar.bz2 5506713 BLAKE2B 775abc8d47f9efac21f28e47d607ab4b07f8948fcca005c78ddb7ed093e51a76f60ac5c04150a3424c360813d180cd1df1ff8a87295918bff872f41123250a58 SHA512 b2b0a8a8db6a52236716fff9748a391388c1b2b1774a26fab9b451b8dab5ff35e8e1403555a65daec180fc961388c7581d170df6e3599a102fd304a133da8674
-DIST heimdall-1.4.2.tar.gz 5486693 BLAKE2B 213bfa5bb7ede8d418847916a5ec16c17e4dec7fcb07de296d96e16c929634167afb57e13cee0e8a6e42fbbddcd2f2e0f5069cfbc3e8c3b5721d2d303ef48407 SHA512 c554662f9ccb763a8e9867a0c563618879d2533af985d44db3c237d3ee51add44c1681d13b1a83b72b30ba6e5b32d7c2f9c02b31114c67c5fbe01cbb010acfe7
+DIST heimdall-2.0.1.tar.gz 83642 BLAKE2B 29cd784a4ea4c25f9670d27c306ca95d60d7ad8a11175d2ee835a0cf1e7fc5eb179aa4e49c5e05e280ed5ce475a9e66e56b48444dd4b3b93ea8cb173e3d18060 SHA512 f6df4551702a7ad7688018d60569b8b94f20be4f78a9b4bf5f6e89396ed43cd7519617ef1f420b41bbfeec8b51ae636759a7b90443d3d5945cd8744b43e2d0ef
+DIST heimdall-2.0.2.tar.gz 83619 BLAKE2B 783f94243730a53f25e8d6d95b4c0839d727a5290aed72948fa7e7a3f4217b3ef1cbfc5e3cd828642d0eb5e965b153097d9dfde11d6fcec2066364a444899f41 SHA512 62849bfe7550214dd774efea65169673fa916f9d204000f793d995aed9def95fcc895c8913cd648f2397ab7fd154257e0394b78c180ed60d043c75858bac7c0a
diff --git a/app-mobilephone/heimdall/heimdall-1.4.2-r1.ebuild b/app-mobilephone/heimdall/heimdall-2.0.1.ebuild
index 9bd4e13eb6db..b1c61d9f7b06 100644
--- a/app-mobilephone/heimdall/heimdall-1.4.2-r1.ebuild
+++ b/app-mobilephone/heimdall/heimdall-2.0.1.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake udev
if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/Benjamin-Dobell/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64"
- S="${WORKDIR}/Heimdall-${PV}"
+ SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64"
+ S="${WORKDIR}/Heimdall-v${PV}"
else
inherit git-r3
- EGIT_REPO_URI="https://github.com/Benjamin-Dobell/Heimdall.git"
+ EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
fi
DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
-HOMEPAGE="https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
+HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
LICENSE="MIT"
SLOT="0"
@@ -46,3 +46,7 @@ src_install() {
udev_dorules heimdall/60-heimdall.rules
dodoc README.md Linux/README
}
+
+pkg_postinst() {
+ udev_reload
+}
diff --git a/app-mobilephone/heimdall/heimdall-1.4.2.ebuild b/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
index ec8238d43d9b..7595551d2aa5 100644
--- a/app-mobilephone/heimdall/heimdall-1.4.2.ebuild
+++ b/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
@@ -1,35 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake udev
if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://gitlab.com/BenjaminDobell/Heimdall/-/archive/v${PV}/Heimdall-v${PV}.tar.bz2 -> ${P}.tar.bz2"
- KEYWORDS="amd64"
+ SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
S="${WORKDIR}/Heimdall-v${PV}"
else
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/BenjaminDobell/Heimdall.git"
+ EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
fi
-DESCRIPTION="Tool suite used to flash firmware onto Samsung Galaxy S devices"
-HOMEPAGE="https://glassechidna.com.au/heimdall/"
+DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
+HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
LICENSE="MIT"
SLOT="0"
IUSE="gui"
RDEPEND="
- >=dev-libs/libusb-1.0.18:1=
sys-libs/zlib
+ virtual/libusb:1=
gui? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
- )
-"
+ )"
+
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -43,9 +43,14 @@ src_configure() {
src_install() {
dobin "${BUILD_DIR}"/bin/heimdall
use gui && dobin "${BUILD_DIR}"/bin/heimdall-frontend
+ udev_dorules heimdall/60-heimdall.rules
+ dodoc README.md Linux/README
+}
- insinto "$(get_udevdir)/rules.d"
- doins heimdall/60-heimdall.rules
+pkg_postinst() {
+ udev_reload
+}
- dodoc README.md Linux/README
+pkg_postrm() {
+ udev_reload
}
diff --git a/app-mobilephone/heimdall/heimdall-9999.ebuild b/app-mobilephone/heimdall/heimdall-9999.ebuild
index e4026eb23735..69599346a8bb 100644
--- a/app-mobilephone/heimdall/heimdall-9999.ebuild
+++ b/app-mobilephone/heimdall/heimdall-9999.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake udev
if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/Benjamin-Dobell/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/Heimdall-${PV}"
+ SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64"
+ S="${WORKDIR}/Heimdall-v${PV}"
else
inherit git-r3
- EGIT_REPO_URI="https://github.com/Benjamin-Dobell/Heimdall.git"
+ EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
fi
DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
-HOMEPAGE="https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
+HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
LICENSE="MIT"
SLOT="0"
@@ -46,3 +46,11 @@ src_install() {
udev_dorules heimdall/60-heimdall.rules
dodoc README.md Linux/README
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-mobilephone/heimdall/metadata.xml b/app-mobilephone/heimdall/metadata.xml
index 499a4a303ee2..1ceb474f6567 100644
--- a/app-mobilephone/heimdall/metadata.xml
+++ b/app-mobilephone/heimdall/metadata.xml
@@ -1,15 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>marco@scardovi.com</email>
- <name>Marco Scardovi</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
+ <remote-id type="sourcehut">~grimler/Heimdall</remote-id>
<remote-id type="github">Benjamin-Dobell/Heimdall</remote-id>
</upstream>
</pkgmetadata>