summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/heimdall/Manifest1
-rw-r--r--app-mobilephone/heimdall/heimdall-2.0.2.ebuild56
-rw-r--r--app-mobilephone/heimdall/heimdall-9999.ebuild6
-rw-r--r--app-mobilephone/heimdall/metadata.xml9
-rw-r--r--app-mobilephone/scrcpy/Manifest8
-rw-r--r--app-mobilephone/scrcpy/scrcpy-2.1.1.ebuild (renamed from app-mobilephone/scrcpy/scrcpy-2.0.ebuild)7
-rw-r--r--app-mobilephone/scrcpy/scrcpy-2.2.ebuild (renamed from app-mobilephone/scrcpy/scrcpy-1.25.ebuild)8
7 files changed, 78 insertions, 17 deletions
diff --git a/app-mobilephone/heimdall/Manifest b/app-mobilephone/heimdall/Manifest
index 3580a15056fb..e9a2e5b5577c 100644
--- a/app-mobilephone/heimdall/Manifest
+++ b/app-mobilephone/heimdall/Manifest
@@ -1 +1,2 @@
DIST heimdall-2.0.1.tar.gz 83642 BLAKE2B 29cd784a4ea4c25f9670d27c306ca95d60d7ad8a11175d2ee835a0cf1e7fc5eb179aa4e49c5e05e280ed5ce475a9e66e56b48444dd4b3b93ea8cb173e3d18060 SHA512 f6df4551702a7ad7688018d60569b8b94f20be4f78a9b4bf5f6e89396ed43cd7519617ef1f420b41bbfeec8b51ae636759a7b90443d3d5945cd8744b43e2d0ef
+DIST heimdall-2.0.2.tar.gz 83619 BLAKE2B 783f94243730a53f25e8d6d95b4c0839d727a5290aed72948fa7e7a3f4217b3ef1cbfc5e3cd828642d0eb5e965b153097d9dfde11d6fcec2066364a444899f41 SHA512 62849bfe7550214dd774efea65169673fa916f9d204000f793d995aed9def95fcc895c8913cd648f2397ab7fd154257e0394b78c180ed60d043c75858bac7c0a
diff --git a/app-mobilephone/heimdall/heimdall-2.0.2.ebuild b/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
new file mode 100644
index 000000000000..7595551d2aa5
--- /dev/null
+++ b/app-mobilephone/heimdall/heimdall-2.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake udev
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+ S="${WORKDIR}/Heimdall-v${PV}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
+fi
+
+DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
+HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gui"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/libusb:1=
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_FRONTEND=$(usex !gui)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/bin/heimdall
+ use gui && dobin "${BUILD_DIR}"/bin/heimdall-frontend
+ udev_dorules heimdall/60-heimdall.rules
+ dodoc README.md Linux/README
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-mobilephone/heimdall/heimdall-9999.ebuild b/app-mobilephone/heimdall/heimdall-9999.ebuild
index b1c61d9f7b06..69599346a8bb 100644
--- a/app-mobilephone/heimdall/heimdall-9999.ebuild
+++ b/app-mobilephone/heimdall/heimdall-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,3 +50,7 @@ src_install() {
pkg_postinst() {
udev_reload
}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-mobilephone/heimdall/metadata.xml b/app-mobilephone/heimdall/metadata.xml
index 9e20ad1856b6..c72a6e44e35e 100644
--- a/app-mobilephone/heimdall/metadata.xml
+++ b/app-mobilephone/heimdall/metadata.xml
@@ -1,14 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>duje.mihanovic@skole.hr</email>
- <name>Duje Mihanović</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="sourcehut">~grimler/Heimdall</remote-id>
</upstream>
diff --git a/app-mobilephone/scrcpy/Manifest b/app-mobilephone/scrcpy/Manifest
index 928d2b985f99..6dab7a18087f 100644
--- a/app-mobilephone/scrcpy/Manifest
+++ b/app-mobilephone/scrcpy/Manifest
@@ -1,4 +1,4 @@
-DIST scrcpy-1.25.tar.gz 345594 BLAKE2B 9be58de258d2e048fc87ef642ba668ad7427faea51d6bd06d48d1ca61a5c55bbce2b758b445d21ea3052ac63809769043e57a28502c53fae98079056029ded1f SHA512 7f28adb69becdc247156d664744ef382cc9ac5e746d2be9c833a53309386c22eb90893b499aee80404cb9903ea40ce5f389b41f2201bf85801e1b8ab920b4eb0
-DIST scrcpy-2.0.tar.gz 375902 BLAKE2B b45a0191a4b634a6fd165a870ce925968eb2bf697eedd88744abf6e6282afa8a4c2108e85e6d479be47e6ddc08a8b5a54875315d1319721639fea8b49f423817 SHA512 c7f6a20ff470c529f3d9a211ee02eebc028f698b2215665c8386afda8db4ea51206bb3c3182d846485399101f0add35844477ebd37df30724cb43c3882c6dc4d
-DIST scrcpy-server-v1.25 42151 BLAKE2B 90789c8b259f9a63820652f8884b51abe1040201f37788542796fbff6445bc13259e2aaf635c99c6ccdb515d8fd4b0b3bcd54d8972d134086f05d149a5073d41 SHA512 2861f423b6c982354c5959570708b51832e18b9d376397f98a78c8d6137af22bb3f19cbce501d7f413276362e9ac9e0358b8984566ff04102a3720074ff1fea1
-DIST scrcpy-server-v2.0 52867 BLAKE2B 6867677059ed60358e8d4f62a01d09d177a52a3ad5d9faf29017666b4566052c9be1777b75df24989d49acf640ff10071daddf760990f18c1df07e1f70c772ff SHA512 366e594ee87101635050185759eb03982b8749f1efe5c8f02d0fb5f60edfdacbd8280a183b872b1484648d2556cbde5abbaf1f3fd92a7f6f604181b9e81ffcde
+DIST scrcpy-2.1.1.tar.gz 386002 BLAKE2B 3d1ec3829cc08d36a6b42f7429749000ea5a4aaf2b8501167fe03b68fb722ec9351da9f287aef752fbceebf04db1484071c4fdf3b84bc5d9eb3805f635502951 SHA512 247d2b4d5523412c667b3104621cdbb5d4a47f1fbc34e4fbde242212d9a4a198232d886eb5d4dc8678fbbe97a63d747827986fd34b08b0951bce02f256e65c47
+DIST scrcpy-2.2.tar.gz 396529 BLAKE2B 6f11dbde6900ef818dbd3e5f1edb169d8acc2a4940675a2cadaec362c1a56c409fe8bcdeab7fcd208c5b4c038d2ddb5da5b0092d5743b27f3719d0970d5553e5 SHA512 e1518d4eb649f40facfd61c8b29120dd11183dd1e753c3b3914794956f87c09777410d0b9f47a05be2763c92c352afd1ee0ac6077d7319e6b29835e1b1259f04
+DIST scrcpy-server-v2.1.1 56995 BLAKE2B 6a089ca33025873f48d62389b17ba6fb6249c007ef7d7fd21883351e7724c3207dce1cea8b655cb949361d26210f5bb6115a2f5f9895c8a3b129652a77848c3d SHA512 f9b27068a92042e6d05ca4d56e6220174fbb008d21c2c423ad3adf91ac1ba0d30cf63a2d9072608adee56f5b49e5a55f9a193737ddf80fb222b447af196c4a90
+DIST scrcpy-server-v2.2 64363 BLAKE2B 65f53a9b931ab076f06de174c1212077d5961a28881237967894ca5f9f59006b4974c4fd6c1e878df9fa7804b848a92b03689f07e27fa32489e66dede5220363 SHA512 7020b3e1b78a9e5896355d22855cffd338d2a455367a82a1aad0659511de42bff8112756ed614b56f9945340aeb56f42f6e093263450c08c02dd8774348dd64a
diff --git a/app-mobilephone/scrcpy/scrcpy-2.0.ebuild b/app-mobilephone/scrcpy/scrcpy-2.1.1.ebuild
index 819f99b5380d..a24a7aa758ab 100644
--- a/app-mobilephone/scrcpy/scrcpy-2.0.ebuild
+++ b/app-mobilephone/scrcpy/scrcpy-2.1.1.ebuild
@@ -24,8 +24,6 @@ RDEPEND="${DEPEND}
!ppc64? ( dev-util/android-tools )"
BDEPEND=""
-PATCHES=( "${FILESDIR}"/${P}-desktop.patch )
-
src_configure() {
local emesonargs=(
$(meson_use lto b_lto)
@@ -36,4 +34,9 @@ src_configure() {
pkg_postinst() {
xdg_pkg_postrm
+
+ einfo "If you use pipewire because of a problem with libsdl2 it is possible that"
+ einfo "scrcpy will not start, in which case start the program by exporting the"
+ einfo "environment variable SDL_AUDIODRIVER=pipewire."
+ einfo "For more information see https://github.com/Genymobile/scrcpy/issues/3864."
}
diff --git a/app-mobilephone/scrcpy/scrcpy-1.25.ebuild b/app-mobilephone/scrcpy/scrcpy-2.2.ebuild
index a244fae445e4..07356869aa7d 100644
--- a/app-mobilephone/scrcpy/scrcpy-1.25.ebuild
+++ b/app-mobilephone/scrcpy/scrcpy-2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,6 @@ DEPEND="media-libs/libsdl2[X]
# Manual install for ppc64 until bug #723528 is fixed
RDEPEND="${DEPEND}
!ppc64? ( dev-util/android-tools )"
-BDEPEND=""
src_configure() {
local emesonargs=(
@@ -34,4 +33,9 @@ src_configure() {
pkg_postinst() {
xdg_pkg_postrm
+
+ einfo "If you use pipewire because of a problem with libsdl2 it is possible that"
+ einfo "scrcpy will not start, in which case start the program by exporting the"
+ einfo "environment variable SDL_AUDIODRIVER=pipewire."
+ einfo "For more information see https://github.com/Genymobile/scrcpy/issues/3864."
}