summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-fuse.patch35
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-norpath.patch11
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-pkgconfig_requires.patch11
-rw-r--r--app-mobilephone/obexftp/obexftp-0.24-r1.ebuild71
4 files changed, 128 insertions, 0 deletions
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-fuse.patch b/app-mobilephone/obexftp/files/obexftp-0.24-fuse.patch
new file mode 100644
index 000000000000..260cfc2d9a56
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-fuse.patch
@@ -0,0 +1,35 @@
+From 2cc82e0ab5a30eaab5461dcc4eed41b095edba3f Mon Sep 17 00:00:00 2001
+From: Hendrik Sattler <post@hendrik-sattler.de>
+Date: Sun, 11 Aug 2013 20:27:29 +0200
+Subject: [PATCH] Install fuse apps
+
+---
+ fuse/CMakeLists.txt | 7 ++++++-
+ 1 files changed, 6 insertions(+), 1 deletions(-)
+
+diff --git a/fuse/CMakeLists.txt b/fuse/CMakeLists.txt
+index c31a5fc..7d5f7ea 100644
+--- a/fuse/CMakeLists.txt
++++ b/fuse/CMakeLists.txt
+@@ -14,7 +14,6 @@ if ( Fuse_FOUND )
+ ${Fuse_LIBRARIES}
+ )
+
+-
+ add_executable ( obexautofs
+ obexautofs.c
+ )
+@@ -23,4 +22,10 @@ if ( Fuse_FOUND )
+ obexftp
+ ${Fuse_LIBRARIES}
+ )
++
++ install ( TARGETS obexfs obexautofs
++ RUNTIME
++ DESTINATION ${CMAKE_INSTALL_BINDIR}
++ COMPONENT applications
++ )
+ endif ( Fuse_FOUND )
+--
+1.7.1
+
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-norpath.patch b/app-mobilephone/obexftp/files/obexftp-0.24-norpath.patch
new file mode 100644
index 000000000000..75a240177182
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-norpath.patch
@@ -0,0 +1,11 @@
+--- obexftp-0.22/swig/perl/Makefile.PL.in.norpath 2007-07-11 21:22:30.000000000 +0200
++++ obexftp-0.22/swig/perl/Makefile.PL.in 2007-08-06 20:17:39.000000000 +0200
+@@ -11,7 +11,7 @@ WriteMakefile(
+ 'INC' => q[-I@top_srcdir@ @CPPFLAGS@],
+ # Default value for LDDLFLAGS is $Config{lddlflags}="-shared -L/usr/local/lib"
+ # but we want rpath to be @libdir@ or @exec_prefix@/lib
+- 'LDDLFLAGS' => q[-shared -Wl,-rpath=@prefix@/lib],
++ 'LDDLFLAGS' => q[-shared],
+ 'LIBS' => q[-L@top_builddir@/obexftp/.libs -lobexftp
+ -L@top_builddir@/multicobex/.libs -lmulticobex
+ -L@top_builddir@/bfb/.libs -lbfb
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-pkgconfig_requires.patch b/app-mobilephone/obexftp/files/obexftp-0.24-pkgconfig_requires.patch
new file mode 100644
index 000000000000..ded4a583330f
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-pkgconfig_requires.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -71,7 +71,7 @@
+ set ( exec_prefix "\${prefix}" )
+ set ( libdir "\${prefix}/${CMAKE_INSTALL_LIBDIR}" )
+ set ( includedir "\${prefix}/${CMAKE_INSTALL_INCLUDEDIR}" )
+-set ( REQUIRES "bluetooth openobex" )
++set ( REQUIRES "bluez openobex" )
+ configure_file (
+ ${CMAKE_CURRENT_SOURCE_DIR}/obexftp.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/obexftp.pc
diff --git a/app-mobilephone/obexftp/obexftp-0.24-r1.ebuild b/app-mobilephone/obexftp/obexftp-0.24-r1.ebuild
new file mode 100644
index 000000000000..90795d59b50d
--- /dev/null
+++ b/app-mobilephone/obexftp/obexftp-0.24-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+inherit cmake-utils python-single-r1 python-utils-r1 eutils multilib
+
+DESCRIPTION="File transfer over OBEX for mobile phones"
+HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+SRC_URI="mirror://sourceforge/openobex/${P}-Source.tar.gz"
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+# bluetooth support is not really optional, bug #529068
+IUSE="perl python ruby tcl" #bluetooth
+
+RDEPEND="
+ >=dev-libs/openobex-1.7
+ net-wireless/bluez
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( || ( dev-lang/ruby:2.0 dev-lang/ruby:1.9 ) )
+ tcl? ( dev-lang/tcl:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ tcl? ( dev-lang/swig )
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${P}-Source
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.23-gentoo.patch
+ "${FILESDIR}"/${PN}-0.24-config.patch
+ "${FILESDIR}"/${PN}-0.24-enable_bluetooth.patch
+ "${FILESDIR}"/${PN}-0.24-python_sitedir.patch
+ "${FILESDIR}"/${PN}-0.24-norpath.patch
+ "${FILESDIR}"/${PN}-0.24-fuse.patch
+ "${FILESDIR}"/${PN}-0.24-pkgconfig_requires.patch
+)
+
+src_configure() {
+# -DENABLE_BLUETOOTH=$(usex bluetooth)
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_SKIP_RPATH=ON
+ -DENABLE_PERL=$(usex perl)
+ -DENABLE_BLUETOOTH=yes
+ -DENABLE_PYTHON=$(usex python)
+ $(usex python -DPYTHON_SITE_DIR=$(python_get_sitedir) '')
+ -DENABLE_RUBY=$(usex ruby)
+ -DENABLE_TCL=$(usex tcl)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${ED}"/usr/share/doc/${PN}/html || die #524866
+}