summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.29.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 20f59006cb3b..8f56847d36c9 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1 +1,2 @@
DIST gnumeric-1.12.27.tar.xz 18558196 SHA256 383a5b6eca17f0a5a0b552edcc10320fa719d10c69c7b6fb29d5a11808f1d1c9 SHA512 7111c311bc7e0ac8e6ad016ff68667b215c1d0aec20d26a573a4c14b4ca3c3fb3002bf6ff15d6472d635ef6f6eadff7532dd65ea00d531a8e15ff24b3d261554 WHIRLPOOL a7a93f4c37f5b30d626c796d516d7ff6bca92845081bc0b92f0f539c023853f095acaf2876e668c650b7ae3375604dc372fdeb9789e8088e6e116306515641f4
+DIST gnumeric-1.12.29.tar.xz 18738564 SHA256 5a35c56679027e5d0e61f67358c2feee458dc0f62494e32281c9a1a579ba7fb5 SHA512 342e0349e251240aaa916fde6eb69ee7588070d979434211b8fd54c6065db33f7148c1c40a954736ef9a7d0271a034f9cee5b66df81abd527504ade678591162 WHIRLPOOL b9541480207ea4175e1b92e75724adfc9bba3530a5b5d63e46d65673a9ab4b03fa900c109722e51df442ec10fac5c27e60d2705b95e163c870296a784da19762
diff --git a/app-office/gnumeric/gnumeric-1.12.29.ebuild b/app-office/gnumeric/gnumeric-1.12.29.ebuild
new file mode 100644
index 000000000000..ba3a957eac68
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.29.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.28:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}