summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-officeext/ooofbtools/ooofbtools-2.34.ebuild')
-rw-r--r--app-officeext/ooofbtools/ooofbtools-2.34.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-officeext/ooofbtools/ooofbtools-2.34.ebuild b/app-officeext/ooofbtools/ooofbtools-2.34.ebuild
new file mode 100644
index 000000000000..85b1763c62d7
--- /dev/null
+++ b/app-officeext/ooofbtools/ooofbtools-2.34.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="OOoFBTools"
+
+OFFICE_EXTENSIONS=(
+ "${MY_PN}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Extension for converting and processing eBooks in FictionBook2 format with validator"
+HOMEPAGE="https://sourceforge.net/projects/fbtools/"
+SRC_URI="mirror://sourceforge/fbtools/files/release/${MY_PN}-${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/libxml2"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+OFFICE_EXTENSIONS_LOCATION="${S}"
+
+src_prepare() {
+ # Remove Windows cruft
+ pushd "${WORKDIR}/${MY_PN}.oxt" 2>/dev/null
+ rm -r win32 || die
+ popd 2>/dev/null
+}
+
+src_install() {
+ office-ext-r1_src_install
+ dodoc ChangeLog*
+}