summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-officeext/ooofbtools/ooofbtools-2.50.ebuild')
-rw-r--r--app-officeext/ooofbtools/ooofbtools-2.50.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-officeext/ooofbtools/ooofbtools-2.50.ebuild b/app-officeext/ooofbtools/ooofbtools-2.50.ebuild
new file mode 100644
index 000000000000..34d38d5a5ec9
--- /dev/null
+++ b/app-officeext/ooofbtools/ooofbtools-2.50.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN="OOoFBTools"
+
+OFFICE_EXTENSIONS=(
+ "${MY_PN}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="OpenOffice extension for the FictionBook2 format with validation"
+HOMEPAGE="https://sourceforge.net/projects/fbtools/"
+SRC_URI="mirror://sourceforge/fbtools/files/release/${MY_PN}-${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/libxml2
+ app-arch/zip"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+OFFICE_EXTENSIONS_LOCATION="${S}"
+
+src_prepare() {
+ # Remove Windows cruft
+ pushd "${WORKDIR}/${MY_PN}.oxt" 2>/dev/null || die
+ rm -r win32 || die
+ popd 2>/dev/null || die
+}
+
+src_install() {
+ office-ext-r1_src_install
+ dodoc ChangeLog*
+}