summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/orange/orange-0.4.ebuild')
-rw-r--r--app-pda/orange/orange-0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-pda/orange/orange-0.4.ebuild b/app-pda/orange/orange-0.4.ebuild
new file mode 100644
index 000000000000..1b7bd82f9b35
--- /dev/null
+++ b/app-pda/orange/orange-0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P=lib${P}
+
+DESCRIPTION="A tool and library for extracting cabs from executable installers"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="app-pda/synce-core
+ >=app-pda/dynamite-0.1.1
+ >=app-arch/unshield-0.6
+ sys-apps/file
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="ChangeLog TODO"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}