summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.32.5.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 900fe09fffcd..ec014b899a2c 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -3,3 +3,4 @@ DIST eix-0.31.7.tar.xz 583100 SHA256 f092c1463a4f49e4b0da97a76b13fd66036a203a590
DIST eix-0.31.9.tar.xz 585724 SHA256 2fa324d2ee242bdc686aaf9e33f591379682e115075eb2212c3b885e2c154267 SHA512 9e58f2fdaac05563e2213bef405ee418507794cf30d9390be341e79e525eee35025458456624b33fe241f2dc8c07ab75fc7a04980a9df9f585cc6bb3d1497ad7 WHIRLPOOL a5bebb53b9a77edb281e5b06b8a6813febde7abdaf69c08ca183d579a56b87eee507ccc406c5717ffcffd0af20f7b3a01f58f7248faf258e451d10fa8cbbcffc
DIST eix-0.32.1.tar.xz 587800 SHA256 706261e2ee99fa4be493691067deb547ce5181e92d5ed6a49d02dc2b1d85ce4f SHA512 deb94d0a9eed7cd895b0cff50db536c2ac1cc6f7031a5b2a98293c02d4e487e63886cc8e9216ad0bea6d66e66d7adf7d875a6537826d479878e2e05d11c50d76 WHIRLPOOL 8dfe92916cb717d8f7d07511e318dfbf1dc266326d162e3d69b091083d58833541804695399d3144935a6af547409efe6000ab14e39b01e0ec6815bcce53e2d1
DIST eix-0.32.4.tar.xz 592284 SHA256 8132be9c496b5b19699c50d9aacd49560ca1f0466e3de4f47b896337f3527fc6 SHA512 382181d082648e9b236c3bf54fdf5d75a8575a7994e6a1d3380e80bcc36ff5779c660c5b5fc5f233cef79e48099fc53bb1c8b87e2ca919dcdb43d5fde276f553 WHIRLPOOL 0c8258d36a30a76fec2e7315e07776c277b2f098f6c0fb0a9a182f28827a659c334b190e10c52ea7ec8facd7a6e1f6124b3ffefd3ed2aade6da747e815276737
+DIST eix-0.32.5.tar.xz 595124 SHA256 1ebe07f46800f3f254d1385cd88eba328da9f07cc17731ad1b231a8b13450f6e SHA512 355c0daf81c349ceaa53a7253816a072578923f2044e53c9a8e98ceb9726b238f86f8b1d8ad96bb62851f887e50c1e5e443115dc12fcae7c8bca851caf9b9650 WHIRLPOOL 3b707ebeadc1653917269c81a594469ff2c603e5ad3772d1b19efb9fbd81dcf76b527c9d03975748e9cf0e1f011d1704ecd39f108ea166d78c9bb3be7370ada7
diff --git a/app-portage/eix/eix-0.32.5.ebuild b/app-portage/eix/eix-0.32.5.ebuild
new file mode 100644
index 000000000000..75a794bf74b4
--- /dev/null
+++ b/app-portage/eix/eix-0.32.5.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PLOCALES="de ru"
+inherit bash-completion-r1 l10n systemd flag-o-matic
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0
+ >=app-shells/quoter-3.0"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT%/}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoicasserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ # https://github.com/vaeth/eix/issues/35
+ append-cxxflags -std=c++11
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ systemd_dotmpfilesd tmpfiles.d/eix.conf
+
+ keepdir /var/cache/eix
+}
+
+pkg_postinst() {
+ if ! use prefix; then
+ # note: if this is done in src_install(), portage:portage
+ # ownership may be reset to root
+ chown portage:portage "${EROOT%/}"/var/cache/eix || die
+ fi
+
+ local obs=${EROOT%/}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT%/}/var/cache/${PN}" || die
+ fi
+}