summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/esearch/esearch-9999.ebuild')
-rw-r--r--app-portage/esearch/esearch-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-portage/esearch/esearch-9999.ebuild b/app-portage/esearch/esearch-9999.ebuild
new file mode 100644
index 000000000000..4db5b2426b45
--- /dev/null
+++ b/app-portage/esearch/esearch-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+PYTHON_REQ_USE="readline(+)"
+
+inherit distutils-r1 git-2
+
+EGIT_REPO_URI="git://github.com/fuzzyray/esearch.git"
+
+DESCRIPTION="Replacement for 'emerge --search' with search-index"
+HOMEPAGE="https://github.com/fuzzyray/esearch"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="linguas_fr linguas_it"
+
+KEYWORDS=""
+
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ python_export_best
+ echo VERSION="9999-${EGIT_VERSION}" "${PYTHON}" setup.py set_version
+ VERSION="9999-${EGIT_VERSION}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc eupdatedb.cron || die "dodoc failed"
+
+ # Remove unused man pages according to the linguas flags
+ if ! use linguas_fr ; then
+ rm -rf "${ED}"/usr/share/man/fr \
+ || die "rm failed to remove ${ED}/usr/share/man/fr"
+ fi
+
+ if ! use linguas_it ; then
+ rm -rf "${ED}"/usr/share/man/it \
+ || die "rm failed to remove ${ED}/usr/share/man/it"
+ fi
+}