summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/genlop')
-rw-r--r--app-portage/genlop/Manifest2
-rw-r--r--app-portage/genlop/files/genlop-0.30.10-sync.patch26
-rw-r--r--app-portage/genlop/files/genlop-0.30.9-display.patch26
-rw-r--r--app-portage/genlop/genlop-0.30.10-r1.ebuild31
-rw-r--r--app-portage/genlop/genlop-0.30.10.ebuild28
-rw-r--r--app-portage/genlop/genlop-0.30.9-r1.ebuild31
-rw-r--r--app-portage/genlop/genlop-9999.ebuild29
-rw-r--r--app-portage/genlop/metadata.xml6
8 files changed, 179 insertions, 0 deletions
diff --git a/app-portage/genlop/Manifest b/app-portage/genlop/Manifest
new file mode 100644
index 000000000000..59a03d77157f
--- /dev/null
+++ b/app-portage/genlop/Manifest
@@ -0,0 +1,2 @@
+DIST genlop-0.30.10.tar.gz 20872 SHA256 690ef95d2ce715f2a1a3a2d380d74958cfdd3a28033625aec6e8d694f91dc4de SHA512 eab59d7dc012fbbdbe7de509deba66e6c7d0c5a37064e79c25a37c64becc259ee5206194615b60b3363022fa59e458356547edca307ceb4e19eeeaf4b146c593 WHIRLPOOL 378e2837929ae21417d3be0b840fb9635248b94cdefef9459455ce80236117c79a9a5f406d707d400e7887f38dbcd5004edd24caac6ebb207ab2f693d4f74bfa
+DIST genlop-0.30.9.tar.gz 21160 SHA256 76aae7055c68bd1bd9f0e17d9e984c32b7e94d4824c9e433f45e3457916f1193 SHA512 659c85bb1d75a90e37449a194fca2c610b2684dab3eb722d566aa929626d958aa1584d12a623f31518d982543be9392786291886ea66a5511e61de1beb3a6936 WHIRLPOOL fab528d251c57541c0cb5e5072d863abf6e776282a64ee3ecfcb88113bac3f1f0256825c0a19fdabbb8f671bc442703a12b28a9d1a4ab7b44c388367ea43dd2c
diff --git a/app-portage/genlop/files/genlop-0.30.10-sync.patch b/app-portage/genlop/files/genlop-0.30.10-sync.patch
new file mode 100644
index 000000000000..8c798dddd18a
--- /dev/null
+++ b/app-portage/genlop/files/genlop-0.30.10-sync.patch
@@ -0,0 +1,26 @@
+From 46eb6a5a9a90049920ea84018b69b643c2809bfa Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Thu, 19 Feb 2015 09:46:47 -0600
+Subject: [PATCH] Fix genlop -r to work with new Portage sync code. (Bug
+ 540050)
+
+---
+ genlop | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/genlop b/genlop
+index e36c678..4e0faf0 100755
+--- a/genlop
++++ b/genlop
+@@ -968,7 +968,7 @@ sub rsync() {
+ my $handle;
+ open_file($_, \$handle);
+ while(<$handle>) {
+- if ($_ =~ m/^(.*?)\: \=\=\= Sync completed with/) {
++ if ($_ =~ m/^(.*?)\: \=\=\= Sync completed/) {
+ if ($date_found) {
+ if (datecompare($1) <= 0) {
+ next;
+--
+2.3.0
+
diff --git a/app-portage/genlop/files/genlop-0.30.9-display.patch b/app-portage/genlop/files/genlop-0.30.9-display.patch
new file mode 100644
index 000000000000..cd9919ee3a27
--- /dev/null
+++ b/app-portage/genlop/files/genlop-0.30.9-display.patch
@@ -0,0 +1,26 @@
+From 76cb98e439c65b5ec8d32d809100a67c653e5635 Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Mon, 21 Jan 2013 15:37:19 -0600
+Subject: [PATCH] Fix issue where genlop <pkg name> no longer displays merge
+ information (Bug 453382).
+
+---
+ genlop | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/genlop b/genlop
+index 52af5ed..d5020eb 100755
+--- a/genlop
++++ b/genlop
+@@ -1127,7 +1127,7 @@ foreach my $ebuild_arg (@targets)
+ }
+ }
+ }
+- if ($list_found or $ebuild_found or $time_found)
++ if ($list_found or $ebuild_found or $time_found or !$info_found)
+ {
+ my $eb = $2;
+ my $extra = $3 || "";
+--
+1.8.1.1
+
diff --git a/app-portage/genlop/genlop-0.30.10-r1.ebuild b/app-portage/genlop/genlop-0.30.10-r1.ebuild
new file mode 100644
index 000000000000..a0f54a0b8f83
--- /dev/null
+++ b/app-portage/genlop/genlop-0.30.10-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base bash-completion-r1
+
+DESCRIPTION="A nice emerge.log parser"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/DateManip
+ dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
+
+# Populate the patches array for any patches for -rX releases
+PATCHES=( "${FILESDIR}"/${P}-sync.patch )
+
+src_install() {
+ dobin genlop
+ dodoc README Changelog
+ doman genlop.1
+ newbashcomp genlop.bash-completion genlop
+}
diff --git a/app-portage/genlop/genlop-0.30.10.ebuild b/app-portage/genlop/genlop-0.30.10.ebuild
new file mode 100644
index 000000000000..8375e1b28e32
--- /dev/null
+++ b/app-portage/genlop/genlop-0.30.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A nice emerge.log parser"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/DateManip
+ dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin genlop
+ dodoc README Changelog
+ doman genlop.1
+ newbashcomp genlop.bash-completion genlop
+}
diff --git a/app-portage/genlop/genlop-0.30.9-r1.ebuild b/app-portage/genlop/genlop-0.30.9-r1.ebuild
new file mode 100644
index 000000000000..1a614276a856
--- /dev/null
+++ b/app-portage/genlop/genlop-0.30.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit base bash-completion-r1
+
+DESCRIPTION="A nice emerge.log parser"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl"
+SRC_URI="mirror://gentoo//${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/DateManip
+ dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
+
+# Populate the patches array for any patches for -rX releases
+PATCHES=( "${FILESDIR}"/${P}-display.patch )
+
+src_install() {
+ dobin genlop || die "failed to install genlop (via dobin)"
+ dodoc README Changelog
+ doman genlop.1
+ newbashcomp genlop.bash-completion genlop
+}
diff --git a/app-portage/genlop/genlop-9999.ebuild b/app-portage/genlop/genlop-9999.ebuild
new file mode 100644
index 000000000000..8f118101b6cb
--- /dev/null
+++ b/app-portage/genlop/genlop-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-2 bash-completion-r1
+
+EGIT_REPO_URI="git://github.com/gentoo-perl/genlop.git"
+DESCRIPTION="A nice emerge.log parser"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/DateManip
+ dev-perl/libwww-perl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin genlop
+ dodoc README Changelog
+ doman genlop.1
+ newbashcomp genlop.bash-completion genlop
+}
diff --git a/app-portage/genlop/metadata.xml b/app-portage/genlop/metadata.xml
new file mode 100644
index 000000000000..f82c90f1e8c4
--- /dev/null
+++ b/app-portage/genlop/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tools-portage</herd>
+ <herd>perl</herd>
+</pkgmetadata>