summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gs-elpa/gs-elpa-0.1.3-r2.ebuild')
-rw-r--r--app-portage/gs-elpa/gs-elpa-0.1.3-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-portage/gs-elpa/gs-elpa-0.1.3-r2.ebuild b/app-portage/gs-elpa/gs-elpa-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..3466a9505488
--- /dev/null
+++ b/app-portage/gs-elpa/gs-elpa-0.1.3-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="g-sorcery backend for elisp packages"
+HOMEPAGE="https://github.com/jauhien/gs-elpa"
+SRC_URI="https://github.com/jauhien/gs-elpa/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-portage/g-sorcery[$(python_gen_usedep 'python*')]
+ dev-python/sexpdata[$(python_gen_usedep 'python*')]"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/${P}-eapi7.patch")
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman docs/*.8
+}