summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/portpeek/portpeek-2.1.26.ebuild')
-rw-r--r--app-portage/portpeek/portpeek-2.1.26.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-2.1.26.ebuild b/app-portage/portpeek/portpeek-2.1.26.ebuild
new file mode 100644
index 000000000000..1fee1c28c074
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.1.26.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.4.0
+ >=sys-apps/portage-2.3.19-r1[${PYTHON_USEDEP}]"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}