summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/portpeek/portpeek-3.2.2-r1.ebuild')
-rw-r--r--app-portage/portpeek/portpeek-3.2.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-3.2.2-r1.ebuild b/app-portage/portpeek/portpeek-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..459e51243625
--- /dev/null
+++ b/app-portage/portpeek/portpeek-3.2.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="https://github.com/mpagano/portpeek"
+SRC_URI="https://github.com/mpagano/portpeek/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.6.1-r1
+ || (
+ >=sys-apps/portage-3.0.31[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}