summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/portpeek')
-rw-r--r--app-portage/portpeek/Manifest3
-rw-r--r--app-portage/portpeek/metadata.xml5
-rw-r--r--app-portage/portpeek/portpeek-3.1.5.ebuild30
-rw-r--r--app-portage/portpeek/portpeek-3.2.4.ebuild (renamed from app-portage/portpeek/portpeek-3.1.4.ebuild)15
4 files changed, 12 insertions, 41 deletions
diff --git a/app-portage/portpeek/Manifest b/app-portage/portpeek/Manifest
index b93b2e5e9788..ac2c786744eb 100644
--- a/app-portage/portpeek/Manifest
+++ b/app-portage/portpeek/Manifest
@@ -1,2 +1 @@
-DIST portpeek-3.1.4.tar.gz 13703 BLAKE2B 9afba0c81e63761160182aaea5f505e640867936e0ac982bfff15dc7c8ae201eede211e04f29b832d8989f9b0e63789234fab08c9cb073ea0d4c7fa96d87d90e SHA512 aae4d79d32c6a8c0bdcce83e3ea67235007db96cc3655e26861b11431bea1e7ac3cf90bed12d3f79cb354381f0590ed0b409c2c7593717ada8b2bf8d8ae4de37
-DIST portpeek-3.1.5.tar.gz 13501 BLAKE2B a22b039e77d3c72c0cfd71e6abb097ed7aa6f0d4b00bb3c4108bda2980ceceedb21d75eb630cbc8eba2d842fd4cbd77c6e8e54c4c842351d2fb86251abbca522 SHA512 8245e40f9a2fada1919583a67de13ba2b6c111c85c9fd0a02e9177e188e2d8edc42882685399f4c61206d4414d4a8296e93d51d4c45ddac0fc968be43a13c639
+DIST portpeek-3.2.4.tar.gz 13655 BLAKE2B bc758a6312775458974bf0cd1218150f18b35cf0722b36829443a7df8e8aaf35b40f2d8edeaad8a21f32b9a5f46ad2eabe7a762286ad62f71f41de08553fbd1c SHA512 2a8d85c1862c3d800251aa94a9ffdee18100aa8d39b6e72dcf8d34c21ac1efb7ef100efe4a3bca5b96570604bfa4b5c4f702ab85f343476ba3081f123d65b5e5
diff --git a/app-portage/portpeek/metadata.xml b/app-portage/portpeek/metadata.xml
index b462e8dac5a2..196eab465c08 100644
--- a/app-portage/portpeek/metadata.xml
+++ b/app-portage/portpeek/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>mpagano@gentoo.org</email>
</maintainer>
<stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">mpagano/portpeek</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-portage/portpeek/portpeek-3.1.5.ebuild b/app-portage/portpeek/portpeek-3.1.5.ebuild
deleted file mode 100644
index bff81b06ffc6..000000000000
--- a/app-portage/portpeek/portpeek-3.1.5.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit python-r1
-
-DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
-HOMEPAGE="https://www.mpagano.com/blog/?page_id=3"
-SRC_URI="https://www.mpagano.com/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- >=app-portage/gentoolkit-0.5.0
- || (
- >=sys-apps/portage-3.0.4[${PYTHON_USEDEP}]
- )"
-
-src_install() {
- python_foreach_impl python_doscript ${PN}
- doman *.[0-9]
-}
diff --git a/app-portage/portpeek/portpeek-3.1.4.ebuild b/app-portage/portpeek/portpeek-3.2.4.ebuild
index c8c2e40c2d4f..f07d14a04f43 100644
--- a/app-portage/portpeek/portpeek-3.1.4.ebuild
+++ b/app-portage/portpeek/portpeek-3.2.4.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{7,8} )
+EAPI="8"
+PYTHON_COMPAT=( python3_{9,10,11,12} )
inherit python-r1
DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
-HOMEPAGE="https://www.mpagano.com/blog/?page_id=3"
-SRC_URI="https://www.mpagano.com/downloads/${P}.tar.gz"
+HOMEPAGE="https://github.com/mpagano/portpeek"
+SRC_URI="https://github.com/mpagano/portpeek/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc sparc x86"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}"
RDEPEND="${DEPEND}
- >=app-portage/gentoolkit-0.4.8
+ >=app-portage/gentoolkit-0.6.3
|| (
- >=sys-apps/portage-3.0.0[${PYTHON_USEDEP}]
+ >=sys-apps/portage-3.0.54-r1[${PYTHON_USEDEP}]
)"
src_install() {