summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/pycargoebuild/pycargoebuild-0.6.1.ebuild')
-rw-r--r--app-portage/pycargoebuild/pycargoebuild-0.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/pycargoebuild/pycargoebuild-0.6.1.ebuild b/app-portage/pycargoebuild/pycargoebuild-0.6.1.ebuild
new file mode 100644
index 000000000000..509b3840a625
--- /dev/null
+++ b/app-portage/pycargoebuild/pycargoebuild-0.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator for Rust/Cargo ebuilds written in Python"
+HOMEPAGE="
+ https://github.com/projg2/pycargoebuild/
+ https://pypi.org/project/pycargoebuild/
+"
+SRC_URI="
+ https://github.com/projg2/pycargoebuild/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest