summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild')
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild
new file mode 100644
index 000000000000..9e516f44532a
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+# Tests need to be fixed
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}