summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-10.2.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index d0b47286838d..a5126f8465cb 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,3 +1,2 @@
-DIST gemato-10.2.tar.gz 63273 BLAKE2B 650f3f9d1c43ee4c8fe1fd53c71fdb818c296141ffdba06371a588d08e6c3f4760c9cd46c4944a11d87cb7026fe13d4576c966275077757f8939452eb1ca15c1 SHA512 51dd55b98acfd22cf3d02a5cb608f6021fd0582c36ef52ac2f0fcb0a66d53ed6abfa546010c2315cabeda839965c8b36da484834bbb2cf6dc23a92b6430acd91
DIST gemato-10.3.tar.gz 63279 BLAKE2B 317c98c3989399e3a87cd5452edc509da86b17ecb41d295feca4071141d3ff1ba95a86544d64c786726f2148a899c1597020dde3513a913b1bc1811e2117337e SHA512 dd2b47238ac0707984358bd763ce0dfb23d8b09561939d22aae2e60386de388af9c5e67faa89a6ab9da4f0b334ee8486eeda66e5eb83bd2a26241b8a2b88128d
DIST gemato-9.3.tar.gz 60601 BLAKE2B d85bf5910736da2ca887567799dee1823e9be6af9b17a8f9deb84ee24bb725c3550aafffa51b15484acb7d37ddbd5996aa4175a8f307b6e3a593f8b5497822be SHA512 7f81409b3b9bd65d295cd760af5cabfc7daf257740f00015f07cd7a0cffd02a40f219b59378179b58bf53b321fb543b308457d3a8b7adcb02981562282f1f46f
diff --git a/app-portage/gemato/gemato-10.2.ebuild b/app-portage/gemato/gemato-10.2.ebuild
deleted file mode 100644
index fc3300922c24..000000000000
--- a/app-portage/gemato/gemato-10.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# pyblake2 & pysha3 are broken with pypy*
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit distutils-r1
-
-DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/mgorny/gemato"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+blake2 bzip2 +gpg lzma +portage-postsync sha3 test"
-
-MODULE_RDEPEND="
- blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
- bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
- gpg? ( app-crypt/gnupg )
- lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
- sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
-
-RDEPEND="${MODULE_RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- portage-postsync? ( app-crypt/gentoo-keys )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${MODULE_RDEPEND} )"
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use portage-postsync; then
- exeinto /etc/portage/repo.postsync.d
- doexe utils/repo.postsync.d/00gemato
- fi
-}