summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/rc/rc-1.7.4-r1.ebuild')
-rw-r--r--app-shells/rc/rc-1.7.4-r1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-shells/rc/rc-1.7.4-r1.ebuild b/app-shells/rc/rc-1.7.4-r1.ebuild
deleted file mode 100644
index 473941979124..000000000000
--- a/app-shells/rc/rc-1.7.4-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A reimplementation of the Plan 9 shell"
-HOMEPAGE="http://static.tobold.org/"
-SRC_URI="http://static.tobold.org/${PN}/${P}.tar.gz"
-
-LICENSE="rc"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="libedit readline"
-
-RDEPEND="readline? ( sys-libs/readline:0 )
- libedit? ( dev-libs/libedit )"
-DEPEND="${RDEPEND}"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-src_configure() {
- local myconf="--with-history"
- use readline && myconf="--with-edit=readline"
- use libedit && myconf="--with-edit=edit"
-
- econf "${myconf}"
-}
-
-src_install() {
- into /usr
- newbin "${PN}" "${PN}sh"
- newman "${PN}.1" "${PN}sh.1"
- einstalldocs
-}
-
-pkg_postinst() {
- if ! grep -q '^/bin/rcsh$' "${EROOT}"/etc/shells ; then
- ebegin "Updating /etc/shells"
- echo "/bin/rcsh" >> "${EROOT}"/etc/shells
- eend $?
- fi
-}