summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/rc/Manifest1
-rw-r--r--app-shells/rc/rc-1.7.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-shells/rc/Manifest b/app-shells/rc/Manifest
index c0c4190614a4..4ca51db6f810 100644
--- a/app-shells/rc/Manifest
+++ b/app-shells/rc/Manifest
@@ -1 +1,2 @@
DIST rc-1.7.2.tbz 153807 SHA256 d4b552b6652a2f85400b61b970c9034b17fcb59b74a0f242bbea12959e8939c7 SHA512 760ee04f2c0fbffc1dddebce35b34183e19e67c2f15fa6c8da83c0305a68114f4aa6af67d33f05c51bcc232a1f7178319eeabd3538fbdf2546742f200457928b WHIRLPOOL c84235fa60cd681e0fefa2f83ac6b5a7d24f3b30f53205ab88cfa94e3e2585e1f8c91062f4c018318d6bb19214e45fc4d418438baeb8d10eb2987518bdce1446
+DIST rc-1.7.4.tar.gz 215206 SHA256 5ed26334dd0c1a616248b15ad7c90ca678ae3066fa02c5ddd0e6936f9af9bfd8 SHA512 49e124207b5370b88b8fba0376dda33451451a58bfb85fabfc06ae59eb88fedf38d7aeaaf292e4f380e2c00efc8301ba68d12180923186d1c53ef94f78f7e435 WHIRLPOOL e7e1e2e68a981bd1a8787f6b90d2d2bbf491e548c18584db6204a06fabd7b88439f9e4fcd0934c1d0c26c903d54a9d9f70c342a66fc00b1138c44f2c1ad12290
diff --git a/app-shells/rc/rc-1.7.4.ebuild b/app-shells/rc/rc-1.7.4.ebuild
new file mode 100644
index 000000000000..55c650d5c2d4
--- /dev/null
+++ b/app-shells/rc/rc-1.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://static.tobold.org/"
+SRC_URI="http://static.tobold.org/${PN}/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="readline? ( sys-libs/readline:0 )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-edit=readline"
+ use libedit && myconf="--with-edit=editline"
+
+ econf \
+ --disable-dependency-tracking \
+ "${myconf}"
+}
+
+src_install() {
+ into /
+ newbin rc rcsh
+ newman rc.1 rcsh.1
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ebegin "Updating /etc/shells"
+ ( grep -v "^/bin/rcsh$" "${ROOT}"etc/shells; echo "/bin/rcsh" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+ eend $?
+}