summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/blogc/blogc-0.7.4.ebuild')
-rw-r--r--app-text/blogc/blogc-0.7.4.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-text/blogc/blogc-0.7.4.ebuild b/app-text/blogc/blogc-0.7.4.ebuild
new file mode 100644
index 000000000000..7b4606390269
--- /dev/null
+++ b/app-text/blogc/blogc-0.7.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="
+ git://github.com/blogc/blogc.git
+ https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+inherit eutils
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="http://blogc.org/"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=""
+
+# pkg-config is used only to find cmocka libraries
+DEPEND="${RDEPEND}
+ test? (
+ virtual/pkgconfig
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ epatch_user
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ --disable-valgrind \
+ ${myconf}
+}