summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cuneiform/files/libm.diff')
-rw-r--r--app-text/cuneiform/files/libm.diff25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/cuneiform/files/libm.diff b/app-text/cuneiform/files/libm.diff
new file mode 100644
index 000000000000..0ab16d58274f
--- /dev/null
+++ b/app-text/cuneiform/files/libm.diff
@@ -0,0 +1,25 @@
+Description: Link the leo and r35 libraries with libm.
+Author: Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>, Jakub Wilk <jwilk@debian.org>
+Forwarded: no
+Last-Update: 2011-07-04
+
+--- a/cuneiform_src/Kern/leo/CMakeLists.txt
++++ b/cuneiform_src/Kern/leo/CMakeLists.txt
+@@ -23,6 +23,7 @@
+ msk32
+ r3532
+ std32
++m
+ )
+
+ library_hook(leo32)
+--- a/cuneiform_src/Kern/r35/CMakeLists.txt
++++ b/cuneiform_src/Kern/r35/CMakeLists.txt
+@@ -3,6 +3,6 @@
+
+ set_property(TARGET r3532 PROPERTY COMPILE_DEFINITIONS __R35__)
+
+-target_link_libraries(r3532 mmx32 std32 cfcompat)
++target_link_libraries(r3532 mmx32 std32 cfcompat m)
+
+ library_hook(r3532)