summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/enscript/enscript-1.6.6.ebuild')
-rw-r--r--app-text/enscript/enscript-1.6.6.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6.ebuild
index 25066b19d186..4246f7c5312f 100644
--- a/app-text/enscript/enscript-1.6.6.ebuild
+++ b/app-text/enscript/enscript-1.6.6.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="2"
+EAPI=6
-inherit eutils
+inherit eutils toolchain-funcs
-DESCRIPTION="powerful text-to-postscript converter"
+DESCRIPTION="Powerful text-to-postscript converter"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
HOMEPAGE="https://www.gnu.org/software/enscript/enscript.html"
@@ -27,26 +27,27 @@ src_prepare() {
epatch "${FILESDIR}"/enscript-1.6.5.2-php.st.patch
use ruby && epatch "${FILESDIR}"/enscript-1.6.2-ruby.patch
sed -i src/tests/passthrough.test -e 's|tail +2|tail -n +2|g' || die
+ default
}
src_configure() {
econf $(use_enable nls)
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README* THANKS TODO || die "dodoc failed"
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
insinto /usr/share/enscript/hl
- doins "${FILESDIR}"/ebuild.st || die "doins ebuild.st failed"
+ doins "${FILESDIR}"/ebuild.st
if use ruby ; then
insinto /usr/share/enscript/hl
- doins "${FILESDIR}"/ruby.st || die "doins ruby.st failed"
+ doins "${FILESDIR}"/ruby.st
fi
}
-
-pkg_postinst() {
- elog "Now, customize /etc/enscript.cfg."
-}