summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/jadetex')
-rw-r--r--app-text/jadetex/jadetex-3.13-r7.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-text/jadetex/jadetex-3.13-r7.ebuild b/app-text/jadetex/jadetex-3.13-r7.ebuild
index 3a80cfceed76..14d37d8b41f7 100644
--- a/app-text/jadetex/jadetex-3.13-r7.ebuild
+++ b/app-text/jadetex/jadetex-3.13-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,9 +20,11 @@ DEPEND=">=app-text/openjade-1.3.1
dev-texlive/texlive-plaingeneric"
src_compile() {
+ fmt_call="$(has_version '>=app-text/texlive-core-2019' \
+ && echo "fmtutil-user" || echo "fmtutil")"
VARTEXFONTS="${T}/fonts" emake
VARTEXFONTS="${T}/fonts" TEXMFHOME="${S}" env -u TEXINPUTS \
- fmtutil --cnffile "${FILESDIR}/format.jadetex.cnf" --fmtdir "${S}/texmf-var/web2c" --all\
+ $fmt_call --cnffile "${FILESDIR}/format.jadetex.cnf" --fmtdir "${S}/texmf-var/web2c" --all\
|| die "failed to build format"
}