summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libetonyek/libetonyek-0.1.10.ebuild')
-rw-r--r--app-text/libetonyek/libetonyek-0.1.10.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-text/libetonyek/libetonyek-0.1.10.ebuild b/app-text/libetonyek/libetonyek-0.1.10.ebuild
deleted file mode 100644
index 212b6c2ce430..000000000000
--- a/app-text/libetonyek/libetonyek-0.1.10.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
- inherit autotools git-r3
-else
- SRC_URI="https://dev-www.libreoffice.org/src/libetonyek/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-fi
-DESCRIPTION="Library parsing Apple Keynote presentations"
-HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
-
-LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-IUSE="doc static-libs test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-RDEPEND="
- app-text/liblangtag
- dev-libs/librevenge
- dev-libs/libxml2
- >=dev-util/mdds-1.5:1=
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- dev-libs/boost
- media-libs/glm
- sys-devel/libtool
- test? ( dev-util/cppunit )
-"
-
-src_prepare() {
- default
- [[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == *9999 ]] && eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-werror
- $(use_with doc docs)
- $(use_enable static-libs static)
- $(use_enable test tests)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -type f -delete || die
-}