summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libgxps')
-rw-r--r--app-text/libgxps/Manifest1
-rw-r--r--app-text/libgxps/libgxps-0.3.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-text/libgxps/Manifest b/app-text/libgxps/Manifest
index 01f2d697f2d9..500f78e73eca 100644
--- a/app-text/libgxps/Manifest
+++ b/app-text/libgxps/Manifest
@@ -1 +1,2 @@
DIST libgxps-0.3.0.tar.xz 93000 BLAKE2B 8e04ae281aa8ee637d597265992a5bf6df3592b7d251d657dae3833c8cca848f7142f926964d96586f50ce9987dee94841be15554a733816a3b4f0acef282f12 SHA512 283ce3041f0238ef1dcae30ce2adbc3f843677e00ae22f20ed3459828f3edaab6d05d87c20dddb613925ab248ed0b29855a94198b982606c3dcb2e59f800b013
+DIST libgxps-0.3.1.tar.xz 93132 BLAKE2B 63af298ef1dc345ef7c40fae4006ba73aa7529381cc6cbc8cf86f4d5b69c8c5617b902bef833ed7d3fa968d927b441e888889179f598b06e2ca13084d3b199af SHA512 80401bd3c9753c74e425c5c08510cac314ad255ebeda9676bd5396a217770c7f5d8733c64b649cc6fdaa43423bb1a4ad21e1e0e3f7903f486e75a1d678850239
diff --git a/app-text/libgxps/libgxps-0.3.1.ebuild b/app-text/libgxps/libgxps-0.3.1.ebuild
new file mode 100644
index 000000000000..bd2e88b54d1c
--- /dev/null
+++ b/app-text/libgxps/libgxps-0.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson xdg-utils
+
+DESCRIPTION="Library for handling and rendering XPS documents"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgxps"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection jpeg lcms tiff"
+
+RDEPEND="
+ >=app-arch/libarchive-2.8
+ >=dev-libs/glib-2.36:2
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=x11-libs/cairo-1.10[svg]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ tiff? ( media-libs/tiff:0[zlib] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ gtk-doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+"
+
+# There is no automatic test suite, only an interactive test application
+RESTRICT="test"
+
+src_configure() {
+ local emesonargs=(
+ -Denable-test=false
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Denable-man=true
+ -Ddisable-introspection=$(usex introspection false true)
+ $(meson_use lcms with-liblcms2)
+ $(meson_use jpeg with-libjpeg)
+ $(meson_use tiff with-libtiff)
+ )
+
+ xdg_environment_reset
+ meson_src_configure
+}