summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libgxps')
-rw-r--r--app-text/libgxps/Manifest1
-rw-r--r--app-text/libgxps/libgxps-0.2.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/libgxps/Manifest b/app-text/libgxps/Manifest
index 3cd5a67f69a6..83bda1a5793d 100644
--- a/app-text/libgxps/Manifest
+++ b/app-text/libgxps/Manifest
@@ -1 +1,2 @@
DIST libgxps-0.2.4.tar.xz 335256 SHA256 e9d6aa02836d9d4823a51705d3e1dee6fc4bce11d72566024042cfaac56ec7a4 SHA512 3e2821931a63483281952d9818dc77295caa8a514d0a25deffd922d98a9db8ced4141cc8489781715a021af361a2e41210aad1fb773f94dff0f864f8e45d2681 WHIRLPOOL 57a7f460e5cfc449b5ca95cd2e8d658d8857b4618cf79896a5da05fbd24e5c38092392f39ef5c96e20b30e1267317ef6e9c3bfd9eada105117bd29a53dd86ebf
+DIST libgxps-0.2.5.tar.xz 346532 SHA256 3e7594c5c9b077171ec9ccd3ff2b4f4c4b29884d26d4f35e740c8887b40199a0 SHA512 f449c4cb989910797c84614ce9f141d4e9adcda0c18f309f656de397ba5deabfa9b4c558c81be7f52bc44c048c401616775989cd1ff9408eeea44f46ef56635b WHIRLPOOL db7514e785f46a3fbf32db9962c2644837855116acbbf37373388c3cfed3b88645c4a574fe8e2ae41913b68250d9448dd3566d9b15b258c74810262f4411f9b8
diff --git a/app-text/libgxps/libgxps-0.2.5.ebuild b/app-text/libgxps/libgxps-0.2.5.ebuild
new file mode 100644
index 000000000000..836732440415
--- /dev/null
+++ b/app-text/libgxps/libgxps-0.2.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Library for handling and rendering XPS documents"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgxps"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug +introspection jpeg lcms static-libs tiff"
+
+RDEPEND="
+ >=app-arch/libarchive-2.8
+ >=dev-libs/glib-2.36:2
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=x11-libs/cairo-1.10[svg]
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1:= )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ tiff? ( media-libs/tiff:0[zlib] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+# There is no automatic test suite, only an interactive test application
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-man \
+ --disable-test \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_with jpeg libjpeg) \
+ $(use_with lcms liblcms2) \
+ $(use_enable static-libs static) \
+ $(use_with tiff libtiff)
+}