summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libstaroffice/libstaroffice-9999.ebuild')
-rw-r--r--app-text/libstaroffice/libstaroffice-9999.ebuild41
1 files changed, 22 insertions, 19 deletions
diff --git a/app-text/libstaroffice/libstaroffice-9999.ebuild b/app-text/libstaroffice/libstaroffice-9999.ebuild
index 7578276aed40..22578cbcb776 100644
--- a/app-text/libstaroffice/libstaroffice-9999.ebuild
+++ b/app-text/libstaroffice/libstaroffice-9999.ebuild
@@ -1,45 +1,48 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
-[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
DESCRIPTION="Import filter for old StarOffice documents"
HOMEPAGE="https://github.com/fosnola/libstaroffice"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
IUSE="debug doc tools +zlib"
-RDEPEND="
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
dev-libs/librevenge
zlib? ( sys-libs/zlib )
"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
-"
+RDEPEND="${DEPEND}"
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_configure() {
- econf \
- --disable-werror \
- $(use_enable debug) \
- $(use_with doc docs) \
- $(use_enable tools) \
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable tools)
$(use_enable zlib zip)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}