summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libstaroffice')
-rw-r--r--app-text/libstaroffice/Manifest1
-rw-r--r--app-text/libstaroffice/libstaroffice-0.0.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/libstaroffice/Manifest b/app-text/libstaroffice/Manifest
index 368e4ecd5f5d..3d11505a4c65 100644
--- a/app-text/libstaroffice/Manifest
+++ b/app-text/libstaroffice/Manifest
@@ -1 +1,2 @@
DIST libstaroffice-0.0.3.tar.xz 679800 SHA256 bedeec104b4cc3896b3dfd1976dda5ce7392d1942bf8f5d2f7d796cc47e422c6 SHA512 ea60576537761a5b969a861ac43c8d4a9da5e5261d0a31f3d7743f8507e6979ccd4cba1784e8c3d909c08b692349ae11e87428834fd3df5b8d56e423caa7bcd8 WHIRLPOOL c8ba69eb347aa0c77f886511d79dba5011aa0ff25c3e9f4ec4af31b8b9303fd9dc1df32742bbc3c87d2a7fba32a7f830fdc3a38ca391559038388f4d97afe9af
+DIST libstaroffice-0.0.4.tar.xz 681828 SHA256 6e728784d002144716b10fe122973b3e4edda9004538386b0b58bb303404903a SHA512 d591e554ce108165f1952ae82835241df0f986ce51f1a4fe43d282733358bb8d72418621f91f431367a5c09f9a40a9784666ffa2da303c5543ee000b1d6abf38 WHIRLPOOL ac295aa290f92bc2071a56439dafb4280c52e2de8e36e6e686cdf31150bff8c87989bbc693cc4175d96c1ae5a155f21bb8f9344b0ed10920ebec161ba20a7110
diff --git a/app-text/libstaroffice/libstaroffice-0.0.4.ebuild b/app-text/libstaroffice/libstaroffice-0.0.4.ebuild
new file mode 100644
index 000000000000..57dbc81af329
--- /dev/null
+++ b/app-text/libstaroffice/libstaroffice-0.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+DESCRIPTION="Import filter for old StarOffice documents"
+HOMEPAGE="https://github.com/fosnola/libstaroffice"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="debug doc tools +zlib"
+
+RDEPEND="
+ dev-libs/librevenge
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ $(use_enable zlib zip)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}