summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild')
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild
new file mode 100644
index 000000000000..6ef28a8e6ba9
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.0.36.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg-utils desktop
+
+DESCRIPTION="Master PDF Editor is a complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="http://code-industry.net/public/${P}_qt5.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+COMMON_DEPEND="
+ >=media-gfx/sane-backends-1.0
+ >=dev-qt/qtsvg-5.4.1:5
+ >=dev-qt/qtnetwork-5.4.1:5
+ >=dev-qt/qtgui-5.4.1:5
+ >=dev-qt/qtprintsupport-5.4.1:5
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+QA_PREBUILT="/opt/${PN}/masterpdfeditor5"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}