summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mathtex/mathtex-1.04.ebuild')
-rw-r--r--app-text/mathtex/mathtex-1.04.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-text/mathtex/mathtex-1.04.ebuild b/app-text/mathtex/mathtex-1.04.ebuild
deleted file mode 100644
index 597f3f4add0f..000000000000
--- a/app-text/mathtex/mathtex-1.04.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs
-
-DESCRIPTION="Lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
-HOMEPAGE="http://www.forkosh.com/mathtex.html"
-SRC_URI="mirror://gentoo/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="png"
-
-RDEPEND="app-text/dvipng
- virtual/latex-base"
-DEPEND="app-arch/unzip"
-
-S=${WORKDIR}
-
-einfo_run_command() {
- einfo "${@}"
- ${@} || die
-}
-
-src_compile() {
- einfo_run_command $(tc-getCC) \
- ${CFLAGS} ${LDFLAGS} \
- -DLATEX=\"/usr/bin/latex\" \
- -DDVIPNG=\"/usr/bin/dvipng\" \
- $(use png && echo "-DPNG") \
- mathtex.c -o mathtex
-}
-
-src_install() {
- dobin mathtex
- dodoc README
- dohtml mathtex.html
-}
-
-pkg_postinst() {
- elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
- elog "to your cgi-bin subdirectory!"
-}