summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mecab/mecab-0.996-r1.ebuild')
-rw-r--r--app-text/mecab/mecab-0.996-r1.ebuild39
1 files changed, 25 insertions, 14 deletions
diff --git a/app-text/mecab/mecab-0.996-r1.ebuild b/app-text/mecab/mecab-0.996-r1.ebuild
index 68305e1647f7..13064cdcfed4 100644
--- a/app-text/mecab/mecab-0.996-r1.ebuild
+++ b/app-text/mecab/mecab-0.996-r1.ebuild
@@ -1,36 +1,42 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
HOMEPAGE="https://taku910.github.io/mecab/"
SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
SLOT="0"
IUSE="static-libs unicode"
-DEPEND="dev-lang/perl
- virtual/libiconv"
-RDEPEND=""
-PDEPEND="|| (
+BDEPEND="
+ dev-lang/perl
+ sys-devel/gettext
+"
+DEPEND="virtual/libiconv"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ || (
app-dicts/mecab-ipadic[unicode=]
app-dicts/mecab-naist-jdic[unicode=]
- )"
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.98-iconv.patch
+ "${FILESDIR}"/${PN}-0.996-clang-16-register.patch
+ "${FILESDIR}"/0001-configure-remove-terrible-horrible-code-that-resets-.patch
+)
-PATCHES=( "${FILESDIR}"/${PN}-0.98-iconv.patch )
HTML_DOCS=( doc/. )
src_prepare() {
default
- sed -i \
- -e "/CFLAGS/s/-O3/${CFLAGS}/" \
- -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
- configure.in
sed -i "s:/lib:/$(get_libdir):" ${PN}rc.in
mv configure.{in,ac} || die
@@ -38,6 +44,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924569
+ # https://github.com/taku910/mecab/issues/75
+ filter-lto
+
econf \
$(use_enable static-libs static) \
$(use_with unicode charset UTF-8)