summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest1
-rw-r--r--app-text/nuspell/nuspell-3.1.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index 79e246255bee..44824bfdad3e 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -1 +1,2 @@
DIST nuspell-3.0.0.tar.gz 403043 BLAKE2B b437012e4fb327f13d9ff0944dadf7e865c670daf153be00dd48e9d2fc01c87d410ebd5aeaa094f6446d3035346738010cdba961cfaada3751bedce264beaa6a SHA512 d9cd7dd276e2bca43dec3abaf11c5206695949b9fda8c9b86f2772cc7e8fa95bf17c685a2ef9ca87fe3c4f0b55f2fcb435bc21c187355f5e3fa35dcafab2c8c2
+DIST nuspell-3.1.0.tar.gz 407196 BLAKE2B 688f6f59ba2f7bceaafe9a7cc707c008be93341e855ca60f07d6de67a626539693048af6f5ca40246ccc51e2573b76ba2bd4439aa9c0acb66a212bebd9219617 SHA512 a9bedfd6e2d77fd34d249cf7aa1fcb6bde5bced26f02f8a2dd860416a61488c9b7016a0df6015052fcccb272b342e6205db601107f46efa44c9d78ce261a826c
diff --git a/app-text/nuspell/nuspell-3.1.0.ebuild b/app-text/nuspell/nuspell-3.1.0.ebuild
new file mode 100644
index 000000000000..84d7b5101d04
--- /dev/null
+++ b/app-text/nuspell/nuspell-3.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="test? ( || ( MPL-1.1 GPL-2+ LGPL-2.1+ ) ) LGPL-3+"
+SLOT="0/3" # due to libnuspell.so.3
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/icu"
+DEPEND="${RDEPEND}
+ doc? ( app-text/ronn )
+ test? ( >=dev-cpp/catch-2.3.0:0 )
+ >=dev-libs/boost-1.62[icu]"
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users . Good luck!'
+ einfo
+}