summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/paperwork-backend/paperwork-backend-1.0.1.ebuild')
-rw-r--r--app-text/paperwork-backend/paperwork-backend-1.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/paperwork-backend/paperwork-backend-1.0.1.ebuild b/app-text/paperwork-backend/paperwork-backend-1.0.1.ebuild
new file mode 100644
index 000000000000..8bc8bc4c7d59
--- /dev/null
+++ b/app-text/paperwork-backend/paperwork-backend-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backend part of Paperwork (Python API, no UI)"
+HOMEPAGE="https://github.com/jflesch/paperwork-backend"
+SRC_URI="https://github.com/jflesch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/poppler[introspection]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/simplebayes[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"